I am currently new to deeper system administration with ubuntu. My new PC has compability problems with ubuntu (to be exact: the WIFI).


In this thread my problem is solved with the last post, but I don't know how to install the backported iwlwifi driver and then where to find the config.

I am using kubuntu 18.04 LTS.

Thanks for your help!

4 Answers 4


To use iwlwifi backports you could

sudo apt-get install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
make defconfig-iwlwifi-public
make -j4
sudo make install
After a reboot check dmesg | grep iwl to see if at least one version of firmware is loaded, you can find the firmware, if needed at https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/

Update for January 2020 The package backport-iwlwifi-dkms is in the Bionic repos and is very similar to the above, this will automatically build new drivers when a newer kernel is installed. There is also a PPA that will have a newer version than what is in the repo, to install this do

sudo add-apt-repository ppa:canonical-hwe-team/backport-iwlwifi
sudo apt-get update
sudo apt install backport-iwlwifi-dkms

  • Did this compile on a ubuntu/debian system? With debian unstable/buster, it gives lots of compiler errors, due to 'versions' file and not finding the linux-headers.
    – Mr. White
    Sep 17, 2018 at 17:44
  • @Mr.White you might need to install the linux-headers-$(uname -r) as it is installed by default in Ubuntu. In Ubuntu the package is called linux-headers-generic
    – Jeremy31
    Sep 17, 2018 at 20:44
  • 1
    If you are getting this error: error: ‘struct iwl_fw_runtime’ has no member named ‘geo_enabled’, you probably want to do git clone https://github.com/intel/backport-iwlwifi and cd backport-iwlwifi/iwlwifi-stack-dev instead Dec 30, 2021 at 1:07

I solved it with upgrading to kernel 4.17.1 from http://kernel.ubuntu.com/~kernel-ppa/mainline/

I installed

  • linux-headers-4.17.1-041701_4.17.1-041701.201806111730_all.deb
  • linux-image-unsigned-4.17.1-041701-generic_4.17.1-041701.201806111730_amd64.deb
  • linux-modules-4.17.1-041701-generic_4.17.1-041701.201806111730_amd64.deb

After that my WIFI-connection was successfully established and the driver works as expected.


Typing sudo apt install backport-iwlwifi-dkms on terminal resolved the issue.


Note: as of Linux 5, backporting iwlwifi is not necessary and may actually break network adapters, both the Intel one and others, due to a conflict with versions of dependency kernel modules such as mac80211.ko and others. (Tested on Debian 10)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.