38

Just noticed this annoying emoji input ("Emoji Choice") popping up every time I press Ctrl+Shift+E in 18.04. I really need this shortcut to switch to the file explorer in Visual Studio Code but instead I only get the emoji input. Is there a way to disable this or at least change the shortcut? Don't want to change the VCS's shortcut because of this, I'm really used to it

5

4 Answers 4

39

Just a small hint: In case you don't find the IBus Preferences dialog, open a Terminal shell and type

ibus-setup

A dialog like this will appear on your screen:

IBus Preferences dialog

2
  • 1
    I had to run sudo ibus-setup due to github.com/ibus/ibus/issues/2098
    – pcnate
    Commented May 11, 2019 at 18:02
  • 1
    I was annoyed. Now I am excited! Now I use <Super>e as shortcut for emoji. But I recommend using containing match. 🥰 Happy typing <(^.^ )>
    – nuiun
    Commented Feb 4, 2021 at 1:20
6

Turned out it was the new ibus version that included the emoji package, I was able to change the shortcut in the ibus settings.

3
  • 1
    I got a fresh Ubuntu 18.04.3 and there is no such thing as ibus-setup (unless you install ibus... even then, the suggestion does not help), no keyboard shortcut in the shortcuts, but <kbd>ctrl</kbd>-<kbd>shift</kbd>-<kbd>E</kbd> indeed triggers emoji mode... so they use another tool?
    – Frank N
    Commented Sep 10, 2019 at 16:04
  • It's very odd. I've tested a live 18.04.3 Ubuntu Mate; there's no ibus package installed, and Ctrl+Shift+E does not enable the emoji input, but it still consumes one extra keypress. I've then tested 19.10 beta, and there's no ibus package installed, and Ctrl+Shift+E doesn't not enable the emoji input nor it consumes an extra keypress. I would therefore seem it's a bug in the input system.
    – Marcus
    Commented Oct 6, 2019 at 20:24
  • For mysterious reasons, today an icon popped up, and it was ibus, which I don't remember installing (I'm not sure it's installed automatically). Note that since the last time I've posted the comment, I moved to Ubuntu MATE 18.04(.4). Anyway, since the icon popped up, removing the ibus hotkey(s) works. Not sure on your setup, but from mine is: dconf write /desktop/ibus/general/hotkey/triggers "@as []". But I think this didn't work on Mint.
    – Marcus
    Commented Mar 13, 2020 at 22:53
5

For VS Code if installed via Ubuntu Snap you need an input method other than ibus.

If you run VS Code from command line do:

$ GTK_IM_MODULE="xim" code

You can also add an alias for that in .bashrc: alias code='GTK_IM_MODULE="xim" code'

To configure the Dash launcher (assuming VS Code is installed using Snap):

  • The launcher file is located at /var/lib/snapd/desktop/applications/code_code.desktop or ~/.local/share/applications/code_code.desktop, or both
  • Edit it and add GTK_IM_MODULE="xim" to Exec commands:
[Desktop Entry]
...
Exec=env GTK_IM_MODULE="xim" BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/code_code.desktop /snap/bin/code --force-user-env --no-sandbox --unity-launch %F
...

[Desktop Action new-empty-window]
...
Exec=env GTK_IM_MODULE="xim" BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/code_code.desktop /snap/bin/code --force-user-env --no-sandbox --new-window %F
Icon=/snap/code/41/meta/gui/com.visualstudio.code.png


1
  • 1
    If you download the official .deb version of VS Code, it works without changing the input method.
    – Albo
    Commented Nov 11, 2021 at 12:50
0

I was unable to make any fix related to ibus work, but adding

export GTK_IM_MODULE="xim"

to my ~/.profile and restarting seems to have done the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .