1

I have Ubuntu Server 18.04 installed on a computer that has 2 internal Hard Drives (/dev/sda and /dev/sdb), I'm trying to mount /dev/sdb to /Volumes/HDD2, but it keeps mounting it to /media/user/HDD2 I already tried what it says here: Another Question but it keeps mounting in another folder, what can I do?

Thanks

1
  • 1
    The question for this answer is not the same as you are asking, but the answer outcome is the same. However, if you want the icon to appear on the desktop you should create the folder for the mount point in the /media folder. If not, you can keep in the /Volumes/HDD2 as like in your question: askubuntu.com/a/860765/231142 Using the UUIDs will prevent the drive designation like /dev/sdb from changing during a reboot if you accidentally leave a USB drive in that could get the drive designation before the internal drives do. – Terrance Jun 13 '18 at 21:15
2

You should use fstab.

Edit /etc/fstab file according to this guide.

As an example you could add a line like this:

/dev/sdb  /Volumes/HDD2      auto    defaults        0       1
3
  • Thanks will do, in the meantime I have another question regarding this same hard drive, after this hard drive is mounted and showing what it has, a day passes and the following day, it's not mounted and when I mount it again it shows gibberish, any ideas? – jfha73 Jun 18 '18 at 13:16
  • If it is correctly inserted in the fstab file, the partition will be mounted on startup. The options are two: either the fstab is configured incorrectly either, at some point, the partition is unmounted by someone or something. Please post the line inserted in the fstab file. – velix Jun 18 '18 at 19:24
  • I edited fstab, but it kept complaining the fs type was wrong, I tried auto and vfat, but none worked, so I ended up deleting the partition and re-creating it, I left it where it mounted it by default (/media/user/HDD2) so far it's working fine. – jfha73 Jun 19 '18 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.