0

I am trying to share a folder between a Windows 10 Host and Ubuntu Guest. I have followed all the steps:

Installed guest additions Settings->Shared Folders-> Added shared folder Tried to mount the folder using "sudo mount -t vboxsf SharedFolder SharedFolder_Location

Nothing is working. The folder never even shows up in the Ubuntu guest. I am not sure what I am doing wrong here, but I am about to give up on VirtualBox. As a side note, I also can't get the copy and paste feature to work either even after setting it to "Bi-directional"

  • It does work. You must install Guest Additions, and read the manual - then it's easy. – user535733 Jun 12 '18 at 20:00
  • I did install Guest Additions. I've uninstalled and reinstalled the virtual machine as well. Still no luck. – Prit1123 Jun 12 '18 at 20:14
  • 1
    "Nothing is working." is not very helpful. What is the error message to the mount command? – muclux Jun 13 '18 at 6:08
0

In the latest version of virtual-box (v5.2 for example), I complete this task without command line:

  1. Open the guest system
  2. Settings -> Shared Folders -> Add, then select the real directory of the folder and name it, and select auto-mounting and fixed-mounting (I use a version not in English, but I think you can see some options similar)
  3. Restart the guest system, then you can see the folder by GUI, like My Computer in win10, or in the sidebar of files in ubuntu

By the way, I have installed the VboxGuestAddtions and the Oracle VM VirtualBox Extension Pack

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.