0

I've already installed VirtualBox via sudo apt-get install virtualbox-5.2 and each time I run VBoxManage -v to ensure VirtualBox is installed I keep getting the following message:

Warning: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (3.18.0-17028-g3f022007a1b8) or it failed to load. Please recompile the kernel module and isntall it by

sudo /sbin/vboxconfig

You will not be able to start VMs until this problem is fixed. 5.2.12r122591

And when I run sudo /sbin/vboxconfig it again asks me to install the Linux kernel "header" file. I've tried sudo apt-get install linux-headers-$(uname -r) and still not working.

Would someone kindly help me with this? I would greatly appreciate your wonderful help.

Thank you

  • What release of Ubuntu? – user535733 Jun 12 '18 at 20:04
  • Ubuntu 16.04 LTS – Nate Jun 12 '18 at 21:53
  • The current kernel version in 16.04 is 4.4, not 3.18. Please confirm your kernel version using the command uname -r. That kernel version string is non-standard. Is there anything about your kernel that you should be telling us? – user535733 Jun 12 '18 at 22:08
  • Correct, the current kernel version I have on my system right now is the 3.18. How do I upgrade to the 4.4 v? Thank you! – Nate Jun 13 '18 at 0:18
  • Kernel 3.18 was never part of 16.04 (indeed, it was not included in any Ubuntu release) which is why you cannot find corresponding Ubuntu header packages). You seem to have an ancient, non-Ubuntu kernel installed. How did you accomplish that? And why? Usually a Frankensystem like this has more surprises lurking. Are you sure there's nothing you want to tell us that would save a lot of everybody's time? – user535733 Jun 13 '18 at 2:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.