7

I have dual-booted Windows and Ubuntu 17.10. In Windows, the shortcut key for task view is Win+Tab. In Ubuntu 17.10, the shortcut key for the Dash menu ("Activities" overview) is the Super key. It's a constant annoyance pressing the wrong key(s) to open up task view/dash when I switch OSs.

So, I'd like to know how to change this shortcut key in Ubuntu 17.10 from just Super to Super+Tab.

This could be done in past versions with the Unity Configuration Editor, but I'm not sure how to do it with GNOME.

1
6

It's actually pretty easy. Pressing alt + f1 should also probably show you the Activities overview, but if you want it to be Super + Tab, then simply open the settings application, and then select the "devices" tab, and under that select "keyboard". You should see a list of your keyboard shortcuts.

Note: The screenshot below is from Ubuntu 18.04 LTS, but it should be the same in Ubuntu 17.10 as well, as long you're using the GNOME Desktop.

Now, you can either search for "activities", or you'll find it under the heading "System":
Gnome Settings You should be able to change it right here. Note that the shortcut for "Switch Applications" under "Navigation" would probably already be Super + Tab. So, if this is the case, and you change the shortcut for "Show the Activities overview" to Super + Tab without changing the shortcut for "Switch Applications", then that will get disabled - so if you want that as well, then choose a different shortcut for that!

Also remember that there is an extension available at https://extensions.gnome.org/ for almost anything you could want to do - so, if you can't find any particular setting in the settings or gnome tweak tool applications, you can just look at this site.

1
  • This does not answer the question. If you delete or modify the Alt+F1 show the activities overview, the Super key is still bound. I am searching for the config file somewhere and it is not in xmodmap. – mosi Nov 13 '19 at 23:37
3

Ubuntu 18.04 finally found the solution

Find out which key is bound to Activity in Gnome:

gsettings get org.gnome.mutter overlay-key

Reset that:

gsettings set org.gnome.mutter overlay-key ''

Originally from:

https://unix.stackexchange.com/questions/388238/how-to-set-super-windows-key-to-show-all-applications-menu-in-gnome-de

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.