0

I'm running Ubuntu Bionic. I installed SLiM display manager so my GUI uses tty2 and I ran vim to edit some C++ code in tty1. Suddenly, it froze completely. I tried to type things but nothing would show up. I used ps -A to find the PID of vim, but even kill 14092 wouldn't work. I used htop and sent process 14092 a SIGTERM, but it hanged there. I sent it a SIGKILL, but it hanged there. I even nuked it with a SIGSEGV, but it still hanged there! How do I stop it?

Thank you very much.

EDIT:

I got it to stop after a reboot (well duh), but how can I do it in the future without the need for a reboot?

6
  • Did you try logging out? I.e. kill the parent, reap the zombie. What state is the process in?
    – ubfan1
    Commented Jun 12, 2018 at 23:15
  • I tried htop and ps -l, but it wouldn't even show the process, only ps -A would ... ??? what is going on ??? ALso, normally zombies would die from being sent a SIGSEGV.
    – Baaing Cow
    Commented Jun 12, 2018 at 23:16
  • Did you press Ctrl + S during your editing? if yes check this answer unix.stackexchange.com/questions/72086/…
    – digiwizkid
    Commented Jun 12, 2018 at 23:25
  • No, I did not press Ctrl-S.
    – Baaing Cow
    Commented Jun 12, 2018 at 23:31
  • Could it be possible the terminal window itself froze and not vim ? Commented Jun 12, 2018 at 23:54

0

You must log in to answer this question.

Browse other questions tagged .