0

I have a Dell xps-13 developer edition. It's default is 14.04 but I updated to 16.04 long ago. Let's just say one stupid decision this morning without coffee lead me to improperly fixing an old bug that resurfaced and I ended up resetting the BIOS settings to factory defaults. I realized my mistake as the Ubuntu booting option dissapeared...

I've since found some possible boot options like EFI/ubuntu/grubx64.efi, which at least get me to grub 2.0. But all the options are for ubuntu 14.04. When I try recovery mode 14.04 using this, it says root system not found and brings me to a initramfs shell which I am not familiar with. I assume just need to get it to mount the proper filesystem?

I believe my 16.04 root filesystem must be somewhere, but I can't find where. Cat /proc/cmdline tells me the boot image and root=UUID=3698.... (long name). The other thing other threads try is fstab /dev/sda1, but I do not have sda of any kind in /dev and /etc/fstab appears empty.

The other thing I've tried is going to the grub command line and using "set root(", TAB gets options (hd0),(hd1error... So apparently whatever hd1 is is also broken. I can set root to either, but hd0 doesn't accept any commands and hd1 just prints failure errors.

Any help would be incredibly appreciated!!

Edit: I've since realized the above EFI options are under (hd0,1)/ and my /home is under (hd0,3).

0

Turns out this is an issue specific to Dell xps models. By resetting the BIOS configuration I turned the SATA configuration from AHCI to RAID. Switching it back allows my filesystem to be found and everything worked out!

So I suggest in general if you can find our filesystem with grub, but it won't boot and commands like fdisk can't find your filesystem, it is probably because they use a different convention RAID vs. AHCI, which as far as I understand are just different programs that assign virtual locations in your disk space.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.