0

I'm trying to use the official ubuntu-18.04-preinstalled-server-armhf+raspi2.img.xz image on my Raspberry PI 3B+. I've followed these instructions: https://wiki.ubuntu.com/ARM/RaspberryPi#Booting_the_official_Pi_2_image_on_the_Pi_3B.2F3B.2B- to convert the image for use on my Pi 3B+.

I can get the machine to boot, but it gets stuck in the boot sequence. The first error is that it fails to load kernel modules. After continuing on, the Pi gets stuck during cloud-init and fails to start the networking service.

I've tried manually copying the kernel modules using these commands in the documentation:

sudo cp /boot/vmlinuz /boot/firmware/
sudo cp /boot/initrd.img /boot/firmware/

Photo of Error

But still, no luck. Any ideas?

0

Failed to load kernel modules is nothing to worry about.

Have you plugged your pi into working Ethernet? From memory this is needed on first boot or it will get stuck. Have you copied the dtb file for the 3B+?

Don't copy those kernel files, you only need to do this if you don't update the flash-kernel database. And you only need to worry about that when you run a package update.

  • You were right, when plugging in Ethernet I made it to the login screen. The username ubuntu and password ubuntu resulted in a failed login. On my second try at making a new image, I get a similar networking error. (picture on original post). Thanks! – Dynamic Jun 11 '18 at 13:27
  • Strange you can't log in. Don't know the answer for that! – Adam Smith Jun 11 '18 at 15:49
  • At the top of the photo it looks like the end of some kind of kernel crash/error? – Adam Smith Jun 11 '18 at 15:50
  • Adam, here it is: i.imgur.com/05x7HlO.jpg – Dynamic Jun 11 '18 at 16:00
  • Lan78xx is the kernel module for your Ethernet. That looks like it is crashing so you don't have Ethernet, so you are getting stuck again. Maybe try writing the image for a third time? – Adam Smith Jun 11 '18 at 18:00
0

I had the same problem. Solved it by deleting /etc/netplan/50-cloud-init.yaml.

  • My /etc/netplan directory was empty on the cloudimg-rootfs partition. – Dynamic Nov 24 '18 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.