6

Is there a way to have my US keyboard behaving the same as Windows and Mac when I use an US international keyboard layout?

My current status is:

  • I can type accents on vowels [OK]

  • I can type ç as ' + c on certain apps, like Firefox, but on others I get ć, like Telegram. I'm aware I can use Alt+, instead. [Partially working]

  • I always need to press space after ', otherwise I can't type I'd or it's or anything like that, which is not the case on Windows or Mac. For my language I'm only interested in accents on vowels other than the ç, and if I type a consonant after ' I'd expect to have it immediately show up as '. [Not OK]

  • This ç thing with ALT also plagues me :/ – Tiago César Oliveira Aug 9 '18 at 11:56
  • AltGr+, will give you ç in US International with dead keys. The keyboards are not the same in Windows, Mac and Linux. There are multiple alternatives, choosing between them is rather subjective, each has its pros and cons, but each layout is normally language-orriented. In what language do you need to write? French? Using multiple layouts is the logical way when writing in different languages, but that can be tough when the physical keyboard is too different; hence the "dead keys" version of a given layout trying to provide a compromise. I would recommend askubuntu.com/a/1045362/925128 – cipricus Sep 9 '19 at 8:44
4

I used 'international with AltGr dead keys' or something like that in 16.04. I could keep the right Alt key depressed to add an accent to just a single letter, and have , ' and " work normally otherwise.

In 18.04 it seems hidden. In "Region & Language" I selected a US keyboard first, and then I could add the "English (intl. with AltGr dead keys)" - after which I could remove the plain US keyboard.

Note that I also moved from IBus to XIM method (it's under Manage Installed Languages - ???) while I did that - no idea if that helped with this change, but I could change it back to IBus anyway.

4

The best solution I've found is to have 2 keyboards installed. In my case:

  1. English (US)
  2. English (US, intl. with dead keys)

I use #1 for no accents where I just type "I'd" and get just that. I use #2 for accents. The keyboard can be selected globally or for each individual window (setting/ Region&Language) the option button to the right of input sources.

Super + space changes between the 2 keyboards.

I have no idea how to address your bullet item 2.

1

To answer number 2 - English (US, intl. with AltGr dead keys) works for ç by using the Alt+, (comma) keys. To capitalize you can simply add Shift.

Hope it helps... I too get annoyed switching back and forward from writing in Portuguese and English. By the way, several other special characters show up on this keyboard, make sure to click the little keyboard button under the Add Language selection to see the layout.

0

I had a similar problem: connecting in ssh with MobaXterm to an Ubuntu 18.04, the AltGr key wasn't working although it was working with other Ubuntu or Centos flavours.

I've fixed that by changing the properties of the terminal from xterm to xterm-r6 .

I do not know what this implies but I'm now happy to not be forced to use ALT+codenumber etc, etc to write a single char. Life is too short! :-)

0

Use the English (US, international AltGr Unicode combining) keyboard. This enables the AltGr (right alt key) to act as an option to access more characters. However, all characters work normally without having to add a space (this is the AltGr combining behavior rather than dead keys enabled).

0

In XUbuntu 18.04:

Open the keyboard window:

enter image description here

Then, Select keyboard layout selection by clicking on Edit and chose the option you like more. In this case English (intl., with AltGr dead keys)

enter image description here

I write this also for myself: for the next laptop, I will have again the same problem and I will search for the solution again and again and again.

0

I had the same problem with AltGr not working and found that in Region & Language you have to Manage Installed Languages and select Keyboard Input Method System to XIM - 18.04 defaults to IBus

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.