1

I have a server running Ubuntu 14.04.4 LTS (GNU/Linux 3.13.0-147-generic x86_64).

After initial setup, I installed and enabled Unattended Upgrades.

For about 9 months Unattended Upgrades worked fine.

However, it seems that about 8 weeks ago it stopped working. On login I now see the notification "79 packages can be updated. 9 updates are security updates."

At this stage I am only concerned about the security updates.

I have tried re-installing Unattended Upgrades. I have also checked the settings which seemed to be most relevant after investigating this matter online. However, nothing seems to work.

I have also tried to upgrade manually using "sudo unattended-upgrade -d". Again, it does not work. It gives the output (here abbreviated):

Initial blacklisted packages: 
Starting unattended upgrades script
Allowed origins are: ['o=Ubuntu,a=trusty-security', 'o=UbuntuESM,a=trusty']
...
pkgs that look like they should be upgraded: 
Fetched 0 B in 0s (0 B/s)                                                                                                                                                      
fetch.run() result: 0
blacklist: []
Packages that will be upgraded: 
InstCount=0 DelCount=0 BrokenCount=0

Can someone help me with this, please?

  • 1
    Please provide the complete (not abbreviated) output. – user535733 Jun 9 '18 at 20:33
  • 1
    Not sure if I understand your question. Doing apt update and apt dist-upgrade do not upgrade the system? – David Tabernero M. Jun 9 '18 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.