3

I am totally new to Ubuntu and a first timer user and been reading about this subject for a while. I have a folder on Windows that I need to be able to access from my Ubuntu VM on Virtual Box.

I did the following steps:

1- From Virtual Box, I went to Devices > Shared Folders > Shared Folder Settings, added a new Shared folder on my windows desktop named 'ubunto_shared' like the following:

following

2- Then from the Ubuntu VM, I ran the following command:

 sudo mount -t vboxsf ubunto_shared windows_shared

But I got the error:

mount: wrong fs type, bad option, bad superblock on ntfs missing codepage or helper program or other error

3- so I installed ntfs-3g using: sudo apt-get install ntfs-3g

4- I then ran this command:

sudo mount -t ntfs-3g ubunto_shared windows_shared

but I got the error:

ntfs-3g: Failed to access volume 'ubunto_shared': No such file or directory

5- I read few articles about how to access that folder, so I ran

sudo /sbin/fdisk -l

I am seeing this and I am not seeing NTFS listed there. How do I handle this issue?

  • you should set the virtualbox as share automount in the vm properties – cmak.fr Jun 9 '18 at 16:20
  • can you please verify what you mean by set vb as share automount? I already specified it as automount as shown in my screenshot, anything else needs to be done? – brittany Jun 9 '18 at 16:23
  • do you have installed 'guest addition' in the ubuntu vm ? – cmak.fr Jun 9 '18 at 16:26
  • @cmak.fr no, all things I did, are the ones I mentioned in my question, nothing more. – brittany Jun 9 '18 at 16:27
  • Are you positive about the name ubunto_shared? Shouldn't it be ubuntu_shared? Did yo create a mount point windows_shared in the guest before mounting? Also see askubuntu.com/questions/161759/… and if that did not help askubuntu.com/questions/30396/… – Takkat Jun 9 '18 at 20:03
1

I faced a similar issue with Lubuntu 18.04/vbox 5.2.1. I did the following: install vbox guest additions, put the user in the vboxsf group. No effect (in versions 16/17 of Ubuntu, usually works).

During the search for a solution, I found many suggestions of packages to be installed, with no effect.

The package that solved for me was: virtualbox-guest-x11. Try:

sudo apt install virtualbox-guest-x11.
0

Your VM need the required Guest Additions modules (drivers)
Your Host need the required VM VirtualBox Extension Pack for advanced features

Download and install the VM VirtualBox Extension Pack (if not yet done)
Install the Guest Additions on your VM :
Virtual Machine running, Menu Device > Install Guest Additions
This will mount an ISO as virtual CD and start the install process


if Virtualbox does not mount the Guest Additions ISO, you may need to download the ISO

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.