1

Just installed Ubuntu 18.04 LTS as a dual-boot alongside Windows, and while I was setting it all up went into the display settings to configure my monitors properly. My primary monitor runs at 1080p 60Hz perfectly on windows, and my secondary runs at 1600x900 @ 60Hz. However, the maximum available refresh rate when I choose 1920x1080 for my primary monitor is 24Hz. I'm using an Nvidia GTX 970 card, and the primary monitor is output to with HDMI.

I disabled the nouveau driver using nomodeset during installation, as there is a bug with it when trying to install ubuntu on a system that uses an Nvidia card, but it appears to be running again now that Ubuntu is fully installed.

0

Fixed it! I did the following:

  1. Use the following tool from Nvidia to search for the driver you need: http://www.nvidia.com/Download/index.aspx?lang=en-us

  2. Reboot your system, and press the E key on the grub bootlader screen with the Ubuntu option selected.

  3. At the end of the "linux" line, add the following:

    nouveau.modeset=0

  4. Press F10 and let it boot.

  5. Before signing in, click the settings button to change from "Ubuntu" to "Ubuntu with Wayland".

  6. Once you are signed in, go into your settings and you should be able to select 1920x1080, with a 60Hz refresh rate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.