4

I installed Bitlocker/Dislocker on my Ubuntu 18.04 to access my USB pen-drive, that is encrypted with Bitlocker, according to Use (Windows) BitLocker-encrypted drive on Ubuntu 14.04 LTS.

It works out if I only have to read files, it doesn't if I try to write them on the mounted folder.

These are the commands I run:

sudo dislocker -V /dev/sda1 -u -- /media/bitlocker
sudo su -
cd /media/bitlocker
sudo mount -o loop,rw dislocker-file /media/mount 

The dislocker-file got its rw attributes:

-rw-rw-rw- 1 root root 1064271872 Jan  1  1970 dislocker-file

The files in /media/mount didn't:

-rwxr-xr-x 1 root root  6316 May 12 18:02 'archive'*

only root is in full control with rwx.

I tried to apply chmod 777 archive , too, I got no errors but also nothing changed in archive file attrubutes.

Maybe the problem is only the mount command but I am not able to find it out.

Could someone help me?

1 Answer 1

2

From dislocker's readme (important parts highlighted by me):

dislocker-fuse: binary using FUSE to dynamically decrypt the BitLocker-ed partition. You have to give it a mount point where, once keys are decrypted, a file named dislocker-file appears. This file is a virtual NTFS partition, so you can mount it as any NTFS partition and then read from or write to it.

...and, in the notes section:

dislocker-fuse: the one you're using when calling `dislocker'

So, as you correctly guessed, the problem boils down to:

How to mount an ntfs partition writable by my user (or everyone)

This question has been asked and answered several times on AskUbuntu. In short:

To change the owning user or group, use the uid and/or gid options. For example: Assuming that your user has uid and gid 1000 (default ids of the first user created in Ubuntu), you could do:

mount -o loop,rw,uid=1000,gid=1000 dislocker-file /media/mount 

Alternatively, you can change the umask to not restrict permissions at all:

mount -o loop,rw,umask=0 dislocker-file /media/mount 

By the way, since you switched to the root user with sudo su -, you can omit sudo from the mount command.

1
  • Your solution solved my problem, thank you very much Danzel. Commented Jun 9, 2018 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .