0

I have issue mounting an usb drive.

After inserting the usb drive, I format disc via Disks app and then create partition ext4.

After confirming the Disks app close.

Then I am trying to mount but without success.

The command that I run is below:

sudo mount -t ext4 /dev/sda1 /media/usbdrive

Error appear:

mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

Create partition screen: https://ibb.co/iqTECo

Disks details: https://ibb.co/cPJLk8

What I am doing wrong?

I want to use this as backup using deja dup.

Thanks

1 Answer 1

1

The error usually appears when the drive is corrupted.
The kernel is unable to read the filesystem superblock, which contains important information regarding the structure of the filesystem.
I suggest you to try formatting the drive once more, using GParted.
Also try creating a smaller partition towards the end of the drive.
It may be that the blocks of the drive at the beginning is damaged.

Update:
Reformatting the drive did not fix the issue.
Using GParted, a new msdos partition table (also called MBR) was created.
Created a new partition and formatted it as Ext4 (quick format).
The drive was able to be mounted successfully.

10
  • Thanks for tip.. But when I open gparted, I don't even see on the list the usb... This was clean usb, I have installed IOS of ubuntu for install. Then I try format and partition, and failed on mount.
    – Zoroaster
    Commented Jun 9, 2018 at 7:40
  • Can you please guide me, even command line or via gui.. for format, partition and mount. thanks
    – Zoroaster
    Commented Jun 9, 2018 at 7:40
  • Sure. Are you on IRC?
    – itsfarseen
    Commented Jun 9, 2018 at 7:41
  • 1
    Thanks for your support. Using gparted and following your instruction worked perfectly.
    – Zoroaster
    Commented Jun 9, 2018 at 8:15
  • 1
    @Farzeen if you gave additional instructions on IRC, please make sure they are included in the answer.
    – danzel
    Commented Jun 9, 2018 at 8:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .