7

Recently i installed Ubuntu 18.04 and started to face a strange issue. while i went to sleep/hibernate mode two of my three USB ports stopped working.

If i restart Ubuntu the USB ports goes back to normal mode.

  • 1
    What is the output of lsusb before and after the sleep – Amith KK Jul 15 '18 at 19:18
2

This answer from Stack Exchange (slightly enhanced here) has a solution:

Edit /etc/default/grub and find the line containing LINUX_DEFAULT change the line from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

Save the file, run sudo update-grub, and reboot.

After using this, you will find:

cat /sys/module/usbcore/parameters/autosuspend
-1

The default value is 2. The kernel parameter changes this value.

Setting the kernel parameter helped me. Now my mice works again, when resuming from suspend.

Suggestion: When USB devices don't work after suspend, you can also reload the driver using the following commands as root:

modprobe -r uhci_hcd
modprobe uhci_hcd

and / or

modprobe -r ehci_hcd
modprobe ehci_hcd
  • This seems to have worked on 18.04.2. – Natetronn Mar 3 '19 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.