2

I have an issue that Ive been researching since 2 months and didn't find anyone yet with that same thing. Hibernation is "important" to me because i like to let linux on a snapshooted way so that I switch to another OS and then come back to the same environment that I was working before on a dual boot machine. So I won't loose hardware resources while on the other OS (I know I could like use virtualBox...) and all applications come back. I use kde session restoring feature but not all applications support the XSM protocol.

Anyway the goal is being able to hibernate (suspend to disk) or recover from a snapshoot of the whole system in any way. Hibernation works on the ubuntu 17.10 (im not sure if i had the nvidia drivers enabled then). But still, even without the nvidia drivers, it hibernates but doesn't recover from it when I boot, which is a known issue due to the metldown kernel patch and seems to be fixable now for ubuntu.

After installing the nvidia driver 390, on all of my hibernation attempts i get stuck ad s2disk message "snapshooting system", then the fans run faster for a while and im forced to force shutdown (alt+print REISUB works too). And yes I've waited like 20 minutes on this screen.

I made a bug report here: https://bugs.launchpad.net/ubuntu/+source/uswsusp/+bug/1770491 But maybe it isn't ubuntu fault. I also did this question and tried all that's there: https://answers.launchpad.net/ubuntu/+question/667833

SPECS Dell i15-7567-A30P Gamer

PROCESSOR: Intel Core i7 7700HQ 7ª Gen. (até 3.8 GHz) Cache 6 MB
RAM: 16 GB DDR4 2133 MHz (suporte até 32 GB)
VIDEO CARD: Geforce GTX 1050 Ti 4 GB GDDR5
STORAGE: Drive primário SSD de 256GB + HD de 1TB (5400 RPM)

SWAP

# swapon -s
Filename                                Type            Size    Used               Priority
/dev/sda8                               partition       16726012        0       -2

The swap works when I fill my ram with random applications so the problem is not it. The swap partition is on the SSD drive(Should i try having it on the hdd?).

The exactly same error happens when I try either the pm-hibernate or hibernate or s2disk commands.

I would like any things or ideas I could still try or any feedback, maybe someone finds out this is a bug on nvidia drivers or i should be installing it from somewhere else or maybe its a bug on the linux kernel itself??? Also I'm open to suggestions besides all i said and the links, for hibernating.

Thanks in advance!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.