0

I've recently purchased a lenovo thinkpad e480 and have attempted to access the internet through the wifi manager. However, in 18.04, there is no option for WiFI networks and when I try to access the wifi settings it says there is no wifi adapter. I've also run iwconfig, with emp3s0 and lo returning as 'no wireless extensions'. The problem persists when I try to run the laptop on 16.04. When I run sudo lshw -C Network, it does return an Ethernet interface and I can view a few pcis through sudo lshw. I've tried running through the wifi troubleshooting on the ubuntu website and cannot find the pci models in their supported chipsets. Could this mean the chipset isn't supported? If so, am I forced to buy a physical wifi adapter?

Thanks in advance

edit: Results of rfkill list all

1: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: No
Hard blocked: No
2: hci0: Bluetooth
Soft blocked: No
Hard blocked: No

Results of sudo lshw -C network

*-network
description: Ethernet interface
product: RTL811/8168/8411 PRI Express Gigabit Ethernet Controller

Running lspci returns several pci bridges and the ethernet controller from the previous command.

9
  • Please edit your question to add the result of the terminal commands: lspci -nnk | grep 0280 -A3 and also: rfkill list all Welcome to Ask Ubuntu.
    – chili555
    Jun 9, 2018 at 1:19
  • thanks for the welcome! I tried running the lspci command but there was no output. I did edit in the rfkill command though. Jun 9, 2018 at 2:12
  • Is wireless disabled in the BIOS? download.lenovo.com/km/media/images/HT071417/…
    – chili555
    Jun 9, 2018 at 13:11
  • @chili555 I checked it and it said that the ethernet interface was enabled. Jun 9, 2018 at 19:29
  • 1
    We see no evidence of an included wireless adapter. I suggest that you question the seller or buy an external device.
    – chili555
    Jun 10, 2018 at 1:14

1 Answer 1

1

The Lenovo e480 comes with an Intel Dual Band Wireless-AC 3165 wifi adapter as far as I know. This should be supported in kernels 4.2+ but perhaps you need to do a little research into how to get it up and running.

Here is the link to Intel's page for downloading the required firmware with some instructions:

Intel Linux Support

Not the answer you're looking for? Browse other questions tagged .