6

I have Ubuntu 18.04 but I installed unity with it.

I have configured switching keyboard languages using ALT+SHIFT using the Text Entry Settings.

However, whenever I restart the computer and the OS starts, it does not work. If I go to the settings again, the ALT+SHIFT still appears there, however only when I clear and re-set this it works again, until I restart again.

gsettings get org.gnome.desktop.input-sources xkb-options

returns:

['grp:lalt_lshift_toggle']

This left alt and left shift I configured with the GNOME Tweak Tool as I found in another question, but it did not help either.

I found that this problems occurs only after the computer wakes up after being suspended. If I restart the computer then it works well and ALT+SHIFT successfully changes the keyboard language.

Did anyone face this issue? Can you help me to solve this annoying problem?

Thank you.

  • Can you please edit your question and show us the output from the command gsettings get org.gnome.desktop.input-sources xkb-options – Gunnar Hjalmarsson Jun 10 '18 at 0:12
  • @GunnarHjalmarsson Thank you, I edited the question – user1002065 Jun 10 '18 at 9:23
  • Then try to remove it: gsettings reset org.gnome.desktop.input-sources xkb-options (my thought is that there may be a conflict) – Gunnar Hjalmarsson Jun 10 '18 at 9:52
  • @GunnarHjalmarsson I tried it, it doesn't help. – user1002065 Jun 10 '18 at 22:22
  • 1
    Any results with the problem? I got the same and out of ideas. – Bulkin Jul 31 '18 at 13:52
2

I haven't found anything better than changing ALT+Shift to Shift+ALT in Text Entry Settings and it's still working after wake up

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.