I get this error when I use apt-get upgrade & apt-get autoremove and on every apt-get [Something].. and when I try to install applications too:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    Solved by executing this command: sudo dpkg-reconfigure -phigh -a Thank you.
    – R9TySix
    Feb 15, 2012 at 18:09
  • 2
    sudo apt-get -f install helps if there are unmet dependencies
    – Stan
    Aug 11, 2016 at 0:21
  • 1
    Do sudo apt purge man-db, then install it again. Jun 25, 2019 at 20:23

6 Answers 6


No solution mentioned in the answers worked for me and I tried a solution mentioned here on Ubuntu Forums, executing the command

sudo dpkg -i --force-all [deb file path]

and that worked.

  • What is [deb file path] ? Mar 27, 2014 at 0:04
  • 1
    That is the path of .deb file Mar 27, 2014 at 9:56
  • 1
    Thanks for replying, and sorry for my ignorance. I had this problem, and I don't know what .deb file you are referring to (I solved the problem using the "delete *.dat" file approach below, but I didn't like that much (like, whoa, this seems hacky) Mar 27, 2014 at 10:13
  • 1
    I strongly will not recommend to use the --force key unless a user fully understands what he is doing. Such options exist only for situations where the user knows that the error will not lead to any serious problems, one must not use it carelessly
    – d.k
    Jan 8, 2015 at 10:34
  • worked great for man-db issues.
    – scipper
    May 30, 2018 at 19:08

Please read the comments below. This may be a dangerous command to run on your system and create an unrecoverable state. (the lines have been commented out to prevent copy-and-paste sysadmin'ing).

Simple and working i tried it !!

sudo -s
# cd /var/cache/debconf
# rm *.dat
apt-get update && apt-get upgrade

Enjoy ;)

  • 1
    I think this might lead to issues as it contains various config files. Feb 23, 2015 at 13:13
  • 1
    instead of rm *.dat I think you should go for mkdir tmp mv *.dat tmp
    – Stanislav
    Sep 4, 2015 at 14:51
  • Did not work in my case, I had to dpkg --purge --force-depends ... some files in order to restore sane functioning. Apr 21, 2016 at 6:42
  • 1
    This produces an error: Errors were encountered while processing: debconf E: Sub-process /usr/bin/dpkg returned an error code (1) Feb 20, 2017 at 16:49
  • This set of commands did not work if drivers (for example) are not configuried properly.
    – mccurcio
    Aug 4, 2020 at 22:50

You may also want to know that you can use dpkg --audit to see what the actual problem is.

If the output is something like:

The following packages are in a mess due to serious problems during installation. 
They must be reinstalled for them (and any packages that depend on them) 
to function properly:
  gcdemu A GNOME panel applet to control CDEmu daemon

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 cdemu-daemon CDEmu daemon
 cdemu-client A simple command-line client to control CDEmu daemon

The following packages are only half configured, probably due to problems
configuring them the first time. The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 transmission-daemon lightweight BitTorrent client (daemon)
 vhba-dkms VHBA virtual host bus adapter module

You could run the command: dpkg --configure <packagename>

 dpkg --configure cdemu-daemon

In order to

Reconfigure an unpacked package. 
If -a  or  --pending  is  given instead of package, all unpacked but unconfigured
packages are configured.

Furthermore you could use:

sudo apt-get -f install
sudo apt-get --reinstall install gcdemu

To fix the packages that are in a mess.

Examples from here: http://ubuntuforums.org/archive/index.php/t-1502826.html

  • 1
    This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – Fabby
    Sep 5, 2015 at 8:03
  • 1
    Agreed, however identifying the problem is part of the solution. I have updated my answer with an example.
    – First Name
    Sep 5, 2015 at 16:21
  • Much better! upvoted!
    – Fabby
    Sep 6, 2015 at 7:15

community wiki answer - solved by OP

This problem was resolved by running the following terminal command:

sudo dpkg-reconfigure -phigh -a
  • sudo: unable to execute /usr/sbin/dpkg-reconfigure: Permission denied Feb 20, 2017 at 16:49
  • 7
    ≻ sudo dpkg-reconfigure -phigh -a Unknown option: a Usage: dpkg-reconfigure [options] packages Nov 7, 2017 at 12:21

You have to run those commands with sudo preceding them so they can be executed with super user credentials Example:

sudo apt-get autoremove "NAME OF PACKAGE HERE"
  • i run sudo -s when i first start terminal.
    – R9TySix
    Feb 15, 2012 at 18:01
  • sudo dpkg-reconfigure -phigh -a this solved the problem Thanks
    – R9TySix
    Feb 15, 2012 at 18:10
  • you made my day Aug 2 at 12:42

If you have deleted /var/cache in a misguided attempt to clean up (like I did), this might fix the issue (it did for me):

sudo mkdir /var/cache/debconf

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .