1

I'm installing Ubuntu 18.04 on my notebook.

When i boot live from USB everything works fine. Then i start installation progress. And everything it's okay.

After rebooting, i get stuck just after I insert login data. Somethimes before, sometimes after. It looks like a graphical issue.

I looked for a solution, but everything tried didn't work. Any hint?

Thank you.

EDIT:

Ubuntu gets stuck at boot screen (freeze, not black) after attempting brightness fix for NVIDIA card

Ubuntu freezes during boot

These solution didn't work. :(

  • Can you please edit your question and tell us anything that you have tried so that we are not doubling up any information that you have already done. Thank you! – Terrance Jun 8 '18 at 13:59
  • Edited! Nothing is working. :( – Miles Davis Jun 8 '18 at 14:05
  • enter the safe mode from the boot menu, wait until you are asked to continue normally, choose that option and see if the system starts the gfx interface. if it works you can go from there. – s1mmel Jun 8 '18 at 23:33
  • 1
    No need to add [Solved] in the title. This is a Q&A site not a forum. So, accepting an answer is enough :) – Kulfy Jan 5 at 10:10
  • I got the same problem only after I installed nvidia-340 (for no actual reason anyway). I booted Ubuntu in recovery mode and apt-purged nvidia-340, and it's booting again. – SOFe Sep 5 at 2:37
4

I found a solution on Ubuntu Forums.

These were the steps to solve the issue (post #3).

  1. Turn on the laptop and press shift or esc during boot to show the GRUB menu
  2. Press e and edit the line starting with linux adding nouveau.modeset=0
  3. Press F10 to boot
  4. Once logged in successfully, go to Activities (top left corner) > Drivers and install suggested nvidia driver.

After these steps everything works perfectly.

I have no idea why it worked. I understand that missing drivers where causing the issue, but can someone elaborate so I can completely understand why this solution actually worked?

The solution was proposed for Ubuntu 16.04. I had ubuntu 16.04 and worked like a charm on my laptop, but Ubuntu 18.04 introduced the same issue. Why?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.