I have two drives set up on my computer; the first is the boot drive that holds Ubuntu 18.04 and is an SSD, the second is a Western Digital drive that I use for storage. Both show up in directory paths for every piece of software I run EXCEPT Firefox! If I select a file or image and do save as, I cannot navigate to, find or see the secondary storage drive!

Anybody have any ideas why this is occurring, and how I might be able to fix this?

Mount Options:

Mount at system startup is checked
Show in use interface is checked
Require additional authorization yada yada yada is NOT checked
NO Display Name
NO Icon Name
NO Symbolic Icon Name
unamed field has these properties: nosuid,nodev,nofail,x-gvfs-show
Mount Point = /mnt/Storage_Disc_01
Identify As = /dev/disk/by-label/Storage_Disc_01
Fiesystem Type = auto

  • How is that partition mounted? (add the mount option to the question please).
    – Rinzwind
    Jun 8, 2018 at 12:26
  • @Rinzwind I've tried both the automount on bootup so the drive appears on the desktop, and the manual mount option; neither one makes a difference. It is also occurring in Chromium (tried that as an alternate browser) Might install Chrome and see what happens. Jun 8, 2018 at 13:53
  • Google Chrome can access all internal and external drives, only the 'new' version of Firefox (quantum?) and Chromium cannot. So far not impressed with 18.04. Jun 14, 2018 at 0:59

1 Answer 1


I had this problem that neither Firefox nor Chrome would recognise additional drives in Ubuntu Bionic Beaver 18.04. Interestingly in Xubuntu, Firefox would recognise other drives but Chrome would not. However I prefer Bionic Beaver and so I looked at other browsers. The only one I found which recognized other drives was Waterfox Web. Unfortunately this browser is too simple for my liking and lacking in features. Amazingly when I next tried Firefox, it recognized all additional drives but Chrome still wouldn’t. I’m no Linux programming expert but my guess is that Web must have provided the necessary links for Firefox. Try it and see; hope it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.