0

System is an old Acer Aspire One running Lubuntu 18.04. Hoping to use an AOC e1649Fwu USB monitor as 2nd display. This page says the latest Displaylink driver (4.2) works with 16.04 + 17.10 -- no mention of 18.04. The Displaylink driver alone did not work on another system on 16.04, however after running the script from Adnan Hodzic here, it's working fine.

I then tried Adnan's script on the Acer, the result of which was a bricked OS. Now I've rebuilt the Acer on 18.04.

The question is- has anyone gotten a Displaylink monitor working on 18.04 yet, and if so, can you share your steps. I'd appreciate knowing what others have done, hoping to avoid bricking this new 18.04 build.

0

I used Adnan Hodzic script to make my displaylink usb-vga working on Ubuntu 18

After launching the script, I chose [U]ninstall in the first time, because I already tried to install the driver manually without success, then I relaunched the script to install drivers, after restarting the machine I got it working. After restarting I typed

$ xrandr --listproviders

It should show only one provider, then I plugged the device, then retype

$ xrandr --listproviders

This time I got two providers, which means that the device has been detected. Finally I activated the device :

$ sudo xrandr --setprovideroutputsource 1 0

Hope this will work for you.

I did something that I do not know if it was necessary, I edited xconf.org by putting inside:

Section "Device"
  Identifier "DisplayLink"
  Driver     "modesetting"
  Option     "PageFlip" "false"
EndSection

p.s. If I do unplug the device, it wont work until I restart the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.