My computer is running on Windows 10 and I want to dual boot it with Ubuntu 18.04.

Disk Sizes are:

C: 148GB  
D: 399GB  
E: 199GB  
F: 155GB  
I: 349MB(System Reserved)

I have freed up 25GB unallocated space from F: drive (which was 180GB). I have MBR partitions and not GPT. Previously my disc was dynamic then I learnt that Ubuntu needs basic disk to be installed. Hence it showed: Ubuntu installer not showing free unallocated space when I had dynamic disk

I converted my dynamic disks to basic disk using AOMEI Dynamic Disk Manager Pro. Here is what my Windows disk management shows:

Disk Manager

but now I see this green box line that says these 4 partition are now "Extended Partition".

I went ahead to install Ubuntu, but all I see in the installer is:

Ubuntu installer not showing my HDD partitions

From the Ubuntu installer, I have run some commands from the terminal, those are:

sudo fdisk -l /dev/sda

sudo fixparts /dev/sda

sudo LC_MESSAGES=POSIX sfdisk -d /dev/sda

Also I have run GParted and it shows:


Please help me regarding this so that I can install Ubuntu in the free space which I had allocated for it, I am stuck in it for a long time.

Edit: After executing the commands given by David Foerster, I decided to run the Ubuntu installer again and the option "Install alongside Windows 10" was also available, but I chose to install Ubuntu in the free space which I created for it by going to the "Something Else" option.Install alongside Windows 10 freespace

  • 1
    You should not have made conversion from GPT to MBR. i guess your system is Booting in the mode "UEFI". Are you able to Boot to Windows at this time? Can you confirm booting mode first to proceed further?
    – PRATAP
    Jun 7, 2018 at 4:19
  • No my computer has MBR and is running on UEFI mode
    – Apurba
    Jun 7, 2018 at 7:15
  • windows 10 cant be run on MBR if the boot mode is in UEFI. are you able to boot to windows in UEFI mode? can you send the pic like this we.tl/HtAe4qiPmI (in windows diskmgmt.msc, select disk0, properties, Volumes tab)
    – PRATAP
    Jun 7, 2018 at 8:30
  • Sorry for the mistake in the previous comment, I meant to say: "No my computer has MBR and is running on BIOS mode". There is no volumes tab when I click on properties on the drives except for the unallocated 25 GB free space. i.stack.imgur.com/cLU28.png
    – Apurba
    Jun 7, 2018 at 8:45
  • 1
    how do I know which is disk 0? For me, it is labelled as Entertainment (E:), Gaming (D:), System (C:) and Stuffs (F:).
    – Apurba
    Jun 7, 2018 at 8:50

1 Answer 1


Your partition table is invalid: primary partition #3 lies within the range of primary partition #4, which isn't too bad because #4 is an extended partition meant to contain logical partitions and #3 doesn't overlap with any of those logical partition, but it's still invalid and a careful partition manager will fail and do nothing instead of making things worse.

You can use fixparts to fix this issue (according to its manual page):

  1. Back up the current Master Boot Record (including the partition table) in case something goes wrong:

    sudo dd if=/dev/sda count=1 > /path/to/sda.mbr

    The path of the back-up file /path/to/sda.mbr should lie on a persistent storage device, e. g. a connected USB drive, as opposed to the ephemeral file system of a live system.

    • If something does go wrong and after you verified that /dev/sda still refers to desired drive (which may change on every boot) you can restore it with the following command:

      sudo dd if=/path/to/sda.mbr of=/dev/sda count=1
      sudo partprobe /dev/sda
  2. Run fixparts with the “logical” (on partition 3), “sort” and “write” (confirmed with yes) commands:

    printf '%s\n' l 3 s w y | sudo fixparts /dev/sda
  • Yes! after executing all the above commands, I decided to run the Ubuntu installer and it finally showed the unallocated 25 GB free space where I successfully installed Ubuntu. Thanks for your help.
    – Apurba
    Jun 8, 2018 at 5:59
  • @Apurba. It's nice to hear that you have succeeded. I would like to know what did you put here "path/to/sda.sfdisk" in sudo sfdisk - d /dev/sda > /path/to/sda.sfdisk and how much time it took to take backup after giving this command. Thank you.
    – PRATAP
    Jun 8, 2018 at 19:13
  • @David Forester you mentioned /path/to/sda.sfdisk do we need to edit /path/to/sda or is it a part of command?
    – PRATAP
    Jun 9, 2018 at 4:22
  • @PRATAP: I clarified the relevant section of my answer. It really needed that improvement. Thanks for pointing it out. Jun 9, 2018 at 7:54
  • @DavidFoerster sudo sfdisk -d /dev/sda > /path/to/sda.sfdisk Didn't work for me, so I tried sfdisk -d /dev/sda > sda.partition.table.08-06-2018.txt and it worked. @PRATAP it didn't take any time, as soon as I executed the command, a text file named sda.partition.table.08-06-2018.txt was created in Home
    – Apurba
    Jun 9, 2018 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.