0

I have a Dell XPS 15 9560 running Ubuntu 18.04 and I can't seem to get the memory card working. Everything I've tried, looking at other threads on here and elsewhere, but to no avail. Below is the details:

 $ lspci -vvnn -s 03:00.0
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
    Subsystem: Dell RTS525A PCI Express Card Reader [1028:07be]
    Physical Slot: 1
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 135
    Region 1: Memory at ed400000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: rtsx_pci
    Kernel modules: rtsx_pci

 $ lsmod | grep rtsx                  
rtsx_usb               20480  0
rtsx_pci_ms            20480  0
memstick               16384  1 rtsx_pci_ms
rtsx_pci_sdmmc         24576  0
rtsx_pci               57344  2 rtsx_pci_sdmmc,rtsx_pci_ms

 $ ls -la /dev | grep mmc
 $ sudo rmmod rtsx_pci_sdmmc rtsx_pci_ms rtsx_pci
 $ sudo modprobe rtsx_pci
 $ ls -la /dev | grep mmc

Based on the above, it's quite clear the module is loaded and ready, but the memory card is not seen by the kernel.

Other people seem to have success by inserting the memory card before boot, but that doesn't seem to work for me.

From memory this worked fine in 17.10.

Any help or pointers would be much appreciated.

  • Yes! I've tried multiple SD cards, none of them work on my laptop, but work on other machines. All the ones I've tried are SDHC – Hosh Sadiq Jun 7 '18 at 20:58
  • SD vs SDHC should not be a problem, as Dell dell.com/en-us/shop/dell-laptops/xps-15/spd/xps-15-9560-laptop says it works. My apologies for the red herring. – K7AAY Jun 7 '18 at 22:34
  • @HoshSadiq, were you able to solve this? I am having similar problem. – Pratik Gaikwad Mar 15 at 20:32
  • @PratikGaikwad Unfortunately I did not. – Hosh Sadiq Mar 16 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.