3

I bought Lenovo ThinkCentre M710q and installed Ubuntu 18.04 on it. During playing Youtube videos, Ubuntu freezed suddenly and then I have to restart computer manually. It happens every time during playing Youtube videos.
The display resolution is:

DP-2 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+

and graphics card is:

WARNING: you should run this program as super-user.
  *-display                 
       description: VGA compatible controller
       product: HD Graphics 530
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:f6000000-f6ffffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.  

I was curious and installed Windows 10 on the computer with following driver:

enter image description here

and I can play several Youtube videos simultaneously. It never crashed.

Does it exist a suitable Intel HD Graphics 530 driver for Ubuntu 18.04? Or what do I have to do?

  • I updated my post. – zero_coding Jun 6 '18 at 19:47
  • Can you please refer to askubuntu.com/a/38369/175814 and add the content of the recommended log files (or links to it if they're too long) to your question? In a vanilla Ubuntu 18.04 setup your display manager would be GDM. – David Foerster Jun 6 '18 at 21:48
  • I updated the kernel of linux to 4.17 and it seems that it does not crashed anymore. But I will post the log anyway. – zero_coding Jun 7 '18 at 5:38
  • If you solved your own problem, please consider to answer your own question and accept your answer. Don’t put the answer in your question or the comments! :-) Thanks. – David Foerster Jun 7 '18 at 9:46
1

In linux, the drivers for the integrated graphics is included in the kernel. However, it seems linux drivers tend to cause more issues than in Windows.

I see two possible solutions:

  1. In Google Chrome(I'm assuming) settings, disable hardware acceleration.
  2. try downgrading/upgrading the linux kernel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.