0

I can login. I was previously unable to click on the 'next' button on the 'welcome to 18.04' splash after login to finally get that off of my screen. But now I can't do anything.

My USB mouse cursor moves, but no buttons work; left, middle, right. I have tried two different mice(?) but still no joy. The left button works fine on the login purple screen, but then it no long works on the desktop. I have (login settings) tried both the GNOME on Xorg, an the Ubuntu, but both have the same problem - buttons don't work!

Looking at other suggestions on other answers, I did sudo ubuntu-drivers autoinstall but no joy. I also do sudo apt update and upgrade, but no joy.

I'm able to login to the computer that has the problem via ssh from another system that is running 17.10.

So my 18.04 computer is totally down and unable to be used. How can I debug/fix this?

  • mouse or trackpad? Please tell exactly what hardware it is – cmak.fr Jun 6 '18 at 12:46
  • if you can access your Ubuntu desktop, press CTRL + ALT + T to open a terminal and type sudo cat /dev/input/mice -> press your mouse button -> if your terminal displays (some exotics) ASCII symbols when you pressed buttons (it does it when you move the mouse too, press the button without moving the mouse), so Ubuntu recognize the mouse, but not your desktop; ifnot, Ubuntu had a big problem about your mouse – damadam Jun 6 '18 at 12:48
  • cmak.fr - as above, USB MOUSE. Notice it works on login. Thanks! – user2565677 Jun 6 '18 at 12:51
  • damadam: tried opening terminal session from both Xorg and Ubuntu setting on login just now; neither will give me a terminal on CTRL+ALT+T. Doing it via ssh shows what looks to be binary on all three buttons: left, right, middle. So system is getting the mouse buttons, just not acting on them. – user2565677 Jun 6 '18 at 12:56
  • Have you installed any GNOME extensions... like Dashboard to Dock? – heynnema Jun 6 '18 at 14:43
0

From the comments...

It was the Workspaces to Dock GNOME extension that caused the mouse and keyboard issues. It's a known problem with this extension. Rename the directory back, and then it should be uninstalled at https://extensions.gnome.org/local/

Update #1:

It seems that the latest update to this GNOME extension has fixed this problem.

Update #2:

Although the extension update fixed the original problem, it created new problems with the workspace overview.

0

@heynneme: you were right, it was the workspaces-to-dock that was the problem. Renaming directory ~/.local/share/gnome-shell/extensions'workspaces-to-doc.... fixed. THANKS! – user2565677 2 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.