0

I'm not able to send email from my website, in webmin I see an see mail queue with a status "address resolver failure". This use to work fine but all of a sudden it got stopped.I'm attaching the screenshot of webmin and my main.cf of postfix

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname
#sender_canonical_maps = hash:/etc/postfix/canonical
sender_dependent_default_transport_maps = hash:/etc/postfix/dependent
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtp_tls_policy_maps = hash:/etc/postfix/tls_policy
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_header_checks = pcre:/etc/postfix/smtp_header_checks
# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

#smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = localhost
#alias_maps = hash:/etc/aliases
#alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, pad10.net, localhost.com, localhost
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = loopback-only
inet_protocols = ipv4

#relayhost = [smtp.gmail.com]:587
relayhost = [smtp.zoho.com]:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_CAfile = /etc/postfix/cacert.pem
smtp_use_tls = yes
#smtp_generic_maps = hash:/etc/postfix/genericsmtpd_sasl_auth_enable = yes
smtpd_sasl_auth_enable = yes
  • This could mean that the email you are trying to send to is not correct, can you try sending an email to of which you are sure it is correct and see if you get the same error? – goedt Jun 6 '18 at 7:58
  • I tried, my office number, Gmail, Yahoo, nada all stuck in mail queue with the same error. Do you see anything wrong in main.cf – Roshan Deshapriya Jun 6 '18 at 8:07
  • Please provide the output of the maillogs under /var/log – s1mmel Jun 6 '18 at 9:20
1

It's resolved. It was following line and I disable it.

#sender_dependent_default_transport_maps = hash:/etc/postfix/dependent

It was looking for things which are not there

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.