9

I installed i3 with sudo apt-get install i3. But if I try to launch it via terminal, it says another window manager is running. In older versions of Ubuntu, there was a round button at the login screen in which we click to select WMs. But in 18.04, there is no such option. How do I launch i3 without making the mess like changing stuff in a file?

  • Did you upgrade from 17.10 as that used Wayland as default graphic server and you'll need to change to X server in the GDM3 custom.conf file. On the other hand a fresh install of 18.04 would still have the X server as default. – xtrchessreal Jun 6 '18 at 9:07
9

Either Log Out or Restart the computer (I recommend a Restart if you are the only user on the machine), and then during the log-in screen, right next to "Log In" button, you will find a small gear icon which will let you change your Window Manager. Keep in mind that this Gear icon will not be visible when you try to access it from the lock screen.

For those of you that are not taken to a login screen, you may have to Disable Automatic Login, it is enabled by default. You can do this by going into: Settings -> Details -> Users -> Turn Off Automatic Login

  • 1
    And for the guys who don't see log-in screen while booting, You have to go to settings>Details>Users>Turn off automatic login.Since automatic login is set True by default – shanmu ganathan Jun 6 '18 at 6:47
  • I just installed 18.04.1 LTS, and i3, and this does not work for me. There is no "Log In" button. The button is called "SIgn In" on my system, and there is no gear icon anywhere. Automatic Login is already turned off. – Laurence Gonsalves Aug 27 '18 at 19:43
  • It turns out you need to reboot the machine (not just log out) after installing i3 to have the gear show up on the login screen. – Laurence Gonsalves Aug 27 '18 at 19:51
  • 1
    @LaurenceGonsalves If you are the only user on an Ubuntu Machine (or on a Machine that uses the GNOME Desktop Environment with GDM) you have no option to Log Out, once you've logged in. Hence, I added either "Log Out or Restart". I will edit the answer to make this more clear. – Tanmay R Sep 9 '18 at 7:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.