1

I've migrated my home directory to a new machine, and now pass wont decrypt my passwords. I think I've narrowed the issue down to gpg2. If I run the command

gpg --decrypt < ~/.password-store/foo

it prompts me for my passphrase (in the CLI) and decrypts the file. However,

gpg2 --decrypt < ~/.password-store/foo

prompts me for my passphrase in pinentry-gtk, but then it outputs

gpg: encrypted with 2048-bit RSA key, ID D86A742B, created 2015-06-15
  "Mark Johnson <mark@barrenfrozenwasteland.com>"
gpg: public key decryption failed: Invalid IPC response
gpg: decryption failed: No secret key

I definitely have the secret key installed:

$ gpg2 --list-secret-keys 
/home/mark/.gnupg/pubring.kbx
-----------------------------
sec   rsa2048/D6E3E9B8 2015-06-15 [SC]
uid         [ultimate] Mark Johnson <mark@barrenfrozenwasteland.com>
ssb   rsa2048/D86A742B 2015-06-15 [E] 

and its definitely tells me its decrypting that key in pinentry-gtk

0

I'm running KDE plasma, and I also have pinentry-qt installed. Uninstalling pinentry-gtk made it use pinentry-qt instead, and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.