0

I recently installed Ubuntu again after having some troubles with my last installation. I've dual booted Ubuntu and Windows before but now i've got some problems.

After the installation Windows disappeared from the GRUB boot menu. I then tried to boot from the disk that my windows is located on, but i still get directly to GRUB, and i guess that's normal.

I've googled around a bit to try to fix this issue, but without success.

I've tried to mount my Windows disk and updating GRUB using update-grub, but it doesn't detect my windows installation.

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-22-generic
Found initrd image: /boot/initrd.img-4.15.0-22-generic
Found linux image: /boot/vmlinuz-4.15.0-20-generic
Found initrd image: /boot/initrd.img-4.15.0-20-generic
done

Using fdisk -l shows my windows disk as following

Disk /dev/sdc: 111,8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xe29d8236

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sdc1            2048 232672357 232670310  111G  7 HPFS/NTFS/exFAT
/dev/sdc2       232673280 234436607   1763328  861M 27 Hidden NTFS WinRE

What is my next step towards solving this, and could someone tell me what may be the cause of this issue, so that i can learn from my mistake?

EDIT: I found out that i accidentally installed in Legacy BIOS mode and not UEFI, and i guess that is why i'm having these issues. While trying to fix this my USB Memory device broke, so i guess i'll have to wait until tomorrow to dig deeper in this.

marked as duplicate by K7AAY, karel, Eric Carvalho, Fabby, Kevin Bowen Jun 14 '18 at 22:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I would run boot-repair – WinEunuuchs2Unix Jun 6 '18 at 1:01
  • @WinEunuuchs2Unix I tried running boot-repair to convert from Legacy BIOS to UEFI, but it doesn't let me do it on a Legacy BIOS version. "The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode. " – Måns Andersson Jun 6 '18 at 1:09
  • Can you type lsblk and add the text output to your answer? – WinEunuuchs2Unix Jun 6 '18 at 1:40

Browse other questions tagged or ask your own question.