3

I have been running Windows 10 pro on a Dell XPS 15 (9560) for some time and would like to dual boot ubuntu. I created an install disk with 18.04 and got similar errors to what are shown below, so I then created a bootable disk using rufus 3.0 with version 16.04 on it hoping this would solve the errors I was getting. I prepared the bios and computer using the very thorough instructions found at https://github.com/rcasero/doc/wiki/Ubuntu-linux-on-Dell-XPS-15-(9560). I get to the GRUB and select the first option, something like "Try Ubuntu without install". When I select this option, the following errors come up:

[   0.037972] ACPI Error:  [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure,
 AE_NOT_FOUND  (20170531/dswload-210)
[   0.037979] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (2017053
1/psobject-252)
[   0.038014] ACPI Exception: AE_NOT_FOUND, (SSDT:xh:rvp11) while loading table
 (20170531/tbxf load-228)
[   0.040866] ACPI Error: 1 table load failures, 12 successful (20170531/tbxf lo
ad-246)
[   12.764409] usb 2-2: device descriptor read/8, error -110
[   18.140497] usb 2-2: device descriptor read/8, error -110
[   21.432576] sd 2:0:0:0: [sda] No Caching mode page found
[   21.432603] sd 2:0:0:0: [sda] Assuming drive cache: write through
[   48.096001] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [plymouthd:298]
[   76.096001] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [plymouthd:298]
[   81.432001] INFO: rcu_sched self-detected stall on CPU
[   81.432038] #0-...: (14999 ticks this GP) idle=e6a/140000000000001/0 softirq=447/447 fqs=7499
[   81.430261] # (t=15000 jiffies g=180 c=181 q=350)

I am not sure what I am doing wrong. I am very new to Ubuntu, I used it some in the past about 6 years ago. I am by no means an advanced user, and have run into quite a bit of trouble trying to install it. Thanks for any help you may be able to offer!

  • Could you try creating your bootable USB on Windows 10 using Rufus (Free & Open Source Bootable USB drive software). Get it from the official website - rufus.akeo.ie - I say this because I can remember having problems using a different version of Ubuntu to create a bootable USB (think i was using 16.04 to create a 14.04 version) and got errors. I think you are saying you used 18.04 to create a 16.04 bootable USB? Have I got that wrong? If you could tell us what method you are using to create a bootable USB and perhaps give Rufus a try, that will help narrow down the possibilities. – pHeLiOn Jun 5 '18 at 15:33
  • Sorry, I forgot to mention that I did create the bootable usb using rufus 3.0. I tried creating the 18.04 bootable USB first, and since it didn't work, I then tried the 16.04 bootable disk and came up with this error. I will edit the post to help avoid any confusion. – M. Plyler Jun 5 '18 at 15:35
  • Ah, then I would assume that the bootable USB is fine. Have you also tried the temporary 'nomodeset' trick from here? - dell.com/support/article/uk/en/ukbsdt1/sln306327/… – pHeLiOn Jun 5 '18 at 16:06
  • I the 'nomodeset' trick is a solution for now. I had read a lot about the 'nomodeset' trick, but I was not understanding where to place the 'nomodeset' in the grub parameters. I have following the directions in the link you posted and this seems to work. I will be installing ubuntu this evening. Thanks for the help! – M. Plyler Jun 5 '18 at 16:35
  • Excellent news - nVidia graphics can be quite pernickety. Glad that's got you past the first bump in the road :) The same link tells you how to adjust it permanently once you have Ubuntu installed. If all goes well, perhaps you could put your solution as an answer so that other people experiencing the same problem can see what might fix the problem for them too? – pHeLiOn Jun 5 '18 at 16:41
3

It appears that the 'nomodeset' trick does the trick! I have now installed Ubuntu 18.04 successfully onto the Dell XPS 15 and it is working fine!

If the bootable USB is set up correctly, and the install/live trial is freezing after the GRUB, then try the following 'nomodeset' trick, as explained in this link provided by pHeLiOn:

http://www.dell.com/support/article/uk/en/ukbsdt1/sln306327/manual-nomodeset-kernal-boot-line-option-for-linux-booting?lang=en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.