2

I upgraded from Ubuntu 17.10 to Ubuntu 18.04. Since then it always gets stuck on shutdown or rebooting while running through some commands. As a result, I have to do a hard reboot by pressing the power button. I have dual boot with Windows 10 with secure boot disabled. When I boot to Ubuntu again, it gets stuck sometimes before login screen with a black screen or after login screen with a purple blank screen but I can login to tty. Though it boots well if I run dpkg from the GRUB menu each time. Even when I can log in, there is no brightness control working. Many times, Ubuntu fails to identify the lan connection. How could I fix the shutdown problem? System info:

Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz Intel Skylake GT2 [HD Graphics 520] AMD radeon R7 M440 Ubuntu 18.04, kernel: 4.15.0-22-generic

1

I got the very simimlar issue. After a new installation of ubuntu 18.04.2 on my laptop, everytime when I try to restart or shutdown the system, it stucks on the shutdown screen with a Ubuntu log like the following screen and I have to press power button to shutdown:

enter image description here

And I solved the problem by switch from Nouveau driver to NVIDIA driver, using Software & Updates App, as following screenshot. The problem disappers after using NVIDIA driver, so I guess there are some potential bugs in Nouveau driver.

enter image description here


And here is my video cards info (the laptop have two video cards, one Intel integrated video card and one NVIDIA card):

$ sudo lshw -c video
# OR
$ sudo lshw -c display
  *-display                 
       description: VGA compatible controller
       product: HD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:b2000000-b2ffffff memory:c0000000-cfffffff ioport:4000(size=64) memory:c0000-dffff
  *-display
       description: 3D controller
       product: GP108M [GeForce MX150]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=nvidia latency=0
       resources: irq:133 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128)

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001D12sv00001D72sd00001604bc03sc02i00
vendor   : NVIDIA Corporation
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin
0

I had the same problem 'stuck at shutdown/reboot' But I found a workaround.

How about trying old linux-kernels ? --- for example, v4.0-vivid, v4.1-wily ~ v4.5-wily

  1. Install ukuu:

    sudo add-apt-repository ppa:teejee2008/ppa
    sudo apt-get update
    sudo apt-get install ukuu
    
  2. Check the list of available kernels:

    sudo ukuu --list
    
  3. install old kernels:

    sudo ukuu --install v4.5-wily
    
  4. Remove current kernel:

    reboot by advanced mode and choose old kernel.open terminal.

    sudo ukuu --remove (current kernel)
    
  • I did not try going back to this long, but I tried a few kernels which were there by default, 4.15.20 and 4.15.18 iirc. That had not helped. But now I have reinstalled Ubuntu overwriting the previous version. – dmishra Aug 10 '18 at 6:15
0

Another dumb solution for Ubuntu 18.04 reboot stuck: I had an American Megatrends BIOS. Once I changed the OS Selection from Windows 7 to Windows 8.X the problem disappeared.

  • I don't get how this is a solution to the stated problem. – Yufenyuy Veyeh Dider Jun 16 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.