0

I tried installing HexBlocker for OpenFOAM precisely according to instructions that are at github HexBlocker wiki and installation failed with errors.

Note: Fresh ("brand new") Ubuntu 18.04 running in VirtualBox (on Win10).

A message from terminal:

of5@of5-VirtualBox~/hexBlocker$ ./install.sh 
+ baseDir=/home/of5/hexBlocker
+ vtkBuild=/home/of5/hexBlocker/build/VTK
+ vtkInstall=/home/of5/hexBlocker/VTK
+ vtkSRC=/home/of5/hexBlocker/vtkSrc
+ hexBuild=/home/of5/hexBlocker/build/hexBlocker
+ hexBin=/home/of5/hexBlocker/bin
+ hexSRC=/home/of5/hexBlocker/src
+ nprocs=4
+ debug=false
++ which qmake
+ QMAKE=/usr/bin/qmake
++ which moc-qt4 moc
++ head -n1
+ MOC=/usr/bin/moc-qt4
++ which uic-qt4 uic
++ head -n1
+ UIC=/usr/bin/uic-qt4
+ '[' -z /usr/bin/qmake -o -z /usr/bin/moc-qt4 -o -z /usr/bin/uic-qt4 ']'
+ vtkpgk=VTK-6.3.0.tar.gz
+ '[' '!' -f VTK-6.3.0.tar.gz ']'
+ '[' '!' -d /home/of5/hexBlocker/vtkSrc ']'
+ '[' '!' -d /home/of5/hexBlocker/build/VTK ']'
+ cd /home/of5/hexBlocker
+ mkdir -p /home/of5/hexBlocker/build/hexBlocker
+ cd /home/of5/hexBlocker/build/hexBlocker
+ cmake -DVTK_DIR=/home/of5/hexBlocker/VTK/lib/cmake/vtk-6.3 -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake -DQT_MOC_EXECUTABLE=/usr/bin/moc-qt4 -DQT_UIC_EXECUTABLE=/usr/bin/uic-qt4 -DCMAKE_INSTALL_PREFIX=/home/of5/hexBlocker/bin /home/of5/hexBlocker/src
CMake Error at CMakeLists.txt:9 (FIND_PACKAGE):
  Could not find a package configuration file provided by "VTK" with any of
  the following names:

    VTKConfig.cmake
    vtk-config.cmake

  Add the installation prefix of "VTK" to CMAKE_PREFIX_PATH or set "VTK_DIR"
  to a directory containing one of the above files.  If "VTK" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/of5/hexBlocker/build/hexBlocker/CMakeFiles/CMakeOutput.log".
+ echo 'error in cmake for hexBlocker'
error in cmake for hexBlocker
+ exit 1
+ make -j 4
make: *** No targets specified and no makefile found.  Stop.
+ echo 'error in make for hexBlocker'
error in make for hexBlocker
+ exit 1
+ make install
make: *** No rule to make target 'install'.  Stop.
+ '[' false == true ']'
+ exit 0

What should I try or change?

  • I suspect it's because the downloaded VTK-6.3.0 failed to build – steeldriver Jun 5 '18 at 0:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.