0

I'm running Ubuntu on a 64-bit computer. I downloaded the file from the official Canon website and installed the 3 drivers for Debian x64. Now whenever I go to settings and look for a printer there's only MF8000C and MF8000C-2. I tried to print through both of these options but nothing printed. I tried restarting the printer and it still didn't work after that.

closed as unclear what you're asking by mikewhatever, Amith KK, MadMike, Eric Carvalho, Kevin Bowen Jun 5 '18 at 21:44

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

0

so perhaps the best way to install the linux package for this is to go here

http://support-asia.canon-asia.com/contents/ASIA/EN/0100924010.html for the 3.5 version of the UFR driver that was updated 8th Feb 2018.

Download and SAVE what will be linux-UFRII-drv-v350-uken.tar.gz and doing it this way, means the install script should do things for you.

So copy each line below; line by line; paste into a terminal; hit the ENTER key; move to next line

cd Downloads

tar -zxvf linux-UFRII-drv-v350-uken.tar.gz

cd linux-UFRII-drv-v350-uken

sudo ./install.sh
  • best before running the above, to delete any existing icons from the PRINTERS folder; (as you say they do not work);

  • If you only report "MF8000C and MF8000C-2", I doubt the system has
    used the Canon drivers; it has used some "near-fit" from its default;

  • (to use a printer, you need to 1) install drivers and 2) register the printer; 2) may NOT necessarily follow from 1)

so the install script in the above is GOOD because Canon ensure you go from 1) to 2) and allocate the correct ppd file to the printer

  • This worked to solve the driver problem, but you also have to open up the canon app from the application menu and there was also a manual setup involved to get the wireless printer working. For those who are also having this problem, the protocol is lpd. – Albert Ai Jun 5 '18 at 20:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.