2

What should i write in the: X-scheme-handler/mailto= ? I have Lotus Notes 8.5.2. It doesnt work if i just trying to change it from System Settings==>Default applications. It doesnt give the option to add Notes as a default but the calendat is ok and been set automaticly since i installed Notes.

Maybe i just need to know the right name of the application ant put it in:

X-scheme-handler/mailto=

Please help.

closed as off-topic by Amith KK, Florian Diesch, Warren Hill, BuZZ-dEE, Richard Apr 2 '14 at 14:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

6

Add the following to the end of /usr/share/applications/LotusNotes8.5.desktop, ie:

sudo gedit /usr/share/applications/LotusNotes8.5.desktop) and save the file:

MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/vnd.mozilla.xul+xml;application/rss+xml;application/rdf+xml;x-scheme-handler/mailto; TargetEnvironment=Messaging Menu;Unity

Next, run the following command:

sudo update-desktop-database -q

Go to System Settings > System Info and click on Default Applications. Lotus Notes 8.5 should now show up as an mail application option.

1

Editing the /usr/shar/.../.desktop shortcut did NOT work for me (13.04 raring).

What got me farther was based on an answer to another question

  1. Edit ~/.local/share/applications/mimeapps.list and add to the Default Applications section:

    x-scheme-handler/mailto=IBMNotes9.0.desktop
    
  2. sudo update-desktop-database

Once I had done that Notes showed as already selected in the "Details" app as my default mail application. Now mailto links will open notes, but it does not open a new composition window.

Any ideas for fixing the last mile here?

0

I had the same problem.

Changing %F to %U in the desktop-file fixed it for me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.