4

While GS65's wifi module, Killer 1550i(which is roughly Intel 9560), doesn't supported in \~4.17 kernels, I managed to get the wifi working by compiling latest iwlwifi kernel module and including them.

But when I recover from the suspend, the wifi module is hard blocked(I could confirm this by sudo rfkill list all).

After the hard block, the airplane mode cannot be turned off by sudo rfkill unblock all or sudo modprobe iwlwifi. Googling suggests to use hardware airplane mode key, which is Fn+F10 on GS65, doesn't work in all situation(before/after hard block).

It's really frustrating since whenever I suspend my laptop for battery I have to reset it. Any help will be great. Thanks in advance!

  • I'm seeing the same issue with my GS65 too even after replacing the internal wifi card with a well supported Intel 8265NGW card instead. I thought this would make all my wifi woes disappear, but life is never that simple. – Gibbsoft Jun 12 '18 at 20:45
9

I have found another work-around for this, although it's not perfect. Whilst airplane mode still will turn itself on and stay on after a suspend, at least this enables the hardware key fn+F10 to allow you to get it back working again. Upon resume just double tap that key combo as quick as you like and you're back online.

To enable fn+F10 add this line to your grub config in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' quiet splash"
  • 2
    As a follow on to Gibbsofts answer, you need to run: grub-mkconfig -o /boot/grub/grub.cfg as root, after you make the edits! – jewnicorn Jul 21 '18 at 23:42
  • 1
    You can run sudo update-grub on Ubuntu to enable the changes. – Waylon Flinn Jul 27 '18 at 16:05
  • this fix works, but then it will always use the discrete nvidia card ... Hibernate is an alternative, but I don't like it. Is there another way to solve this? – RaptoX May 23 at 19:57
1

I have the same problem (with BestBuy model gs65) with Intel AC9560 wifi card on ubuntu 18.04. I found workaround with this issue to enable lid close action with hibernating mode instead undefined in the /etc/systemd.logind.conf. 1. Open terminal to edit the /etc/systemd/logind.conf file. sudo gedit /etc/systemd/logind.conf 2. Search for HandleLidSwitch line. HandleLidSwitch=hibernate, hibernate when lid is closed 3. need to test if hibernate works first (if not make sure the swap space is larger than ram size. For BestBuy model, need to at lease 16G).

Hope it is working for you :-).

  • I can confirm that if you hibernate rather than suspend, the wireless card won't be blocked. I also own a gs65 and use nixos – redfish64 Jul 8 '18 at 12:02
  • @dave88 I already knew this but hibernation just sucks so hard lol – user3498780 Jul 14 '18 at 1:12

protected by Community Jul 31 '18 at 10:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.