2

I have a .sh file that I would run on Ubuntu 16.04 that calibrated my Tablet Monitor. It worked perfectly fine, but like many things, upgrading to 18.04 made that script stop running automatically on startup.

The file is executable and I've added it using the Startup Applications Preferences. Per a suggestion on another person's thread, I tried adding sh to the beginning of the filepath, that also didn't work.

Here's my script below. the filename is xinput.sh.

#!/bin/bash

xinput set-prop 16 --type=float "Coordinate Transformation Matrix" 0.5 0 0 0 1 0 0 0 1

xinput set-button-map 9 1 3 2

screencap of my Startup Applications Preferences

  • You could edit the script to echo debugging and log messages to a log file, so you can see what is going on. – Jos Jun 4 '18 at 14:37
  • Post your script . And by "on launch" do you mean at the time of login or do you want the script to run at boot? Are you running X or wayland ? – Panther Jun 4 '18 at 14:38
  • Here's my Script: paste.ubuntu.com/p/ByR5MqmjbZ Here's a screenshot of my start application setup: imgur.com/a/bIkRlhL And by "on launch" I mean at the time of login. That seems like the most relevant point to run a script like this. I'm not running wayland. So I guess that means I'm running x. I'll double check that in a moment. Edit: Yeah, "Gnome on Xorg" – bryanwillis7 Jun 4 '18 at 15:27
  • 1
    First I would like to welcome you to Askubuntu! Now for some mentoring on using the system. Your question is vague. Panther's suggestion of posting your script was for you to fix your question... making it clearer. Please copy and paste the text you placed in a link, to your question. Click edit. This will substantially increase the attention that you will get for your question. It'll make it easier for us to see your problem. Having to leave the site is extra work and distracting when it doesn't have to be. – L. D. James Jun 4 '18 at 15:37
  • 1
    Possible duplicate of "Startup Applications" not working – Jacob Vlijm Jul 26 '18 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.