0

I have tried the solution in this thread.

Even after running the command

echo "options rtl8723be ant_sel=2" | sudo tee -a /etc/modprobe.d/rtl8723be.conf

It is not persisting after the restart.

After reboot I have to do the whole process again in the thread mentioned above. Any better solution for the changes to persist even after restart.

details of my wifi card

*-network                
   description: Ethernet interface
   product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 07
   serial: dc:4a:3e:d6:5f:9e
   size: 10Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet >physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 >driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 >latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:124 ioport:4000(size=256) memory:a1200000-a1200fff >memory:a1000000-a1003fff
*-network
   description: Wireless interface
   product: RTL8723BE PCIe Wireless Network Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 00
   serial: 48:e2:44:b1:bd:79
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical >wireless
   configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-22->generic firmware=N/A ip=192.168.0.104 latency=0 link=yes multicast=yes >wireless=IEEE 802.11
   resources: irq:17 ioport:3000(size=256) memory:a1100000-a1103fff

dmesg | grep rtl output:

[   19.696873] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[   19.696875] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   19.720304] rtlwifi: loading out-of-tree module taints kernel.
[   19.720352] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
[   19.768383] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   19.768386] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   20.252762] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
[   20.484375] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   20.484553] rtlwifi: rtlwifi: wireless switch is on
[   24.174027] rtl8723be 0000:03:00.0 wlp3s0: renamed from wlan0
[   36.012671] rtl8723be: **** _rtl8723be_phy_path_a_iqk: reg 0x948 0x0
[   36.022650] rtl8723be: **** _rtl8723be_phy_path_a_rx_iqk: reg 0x948 0x0
[   36.048636] rtl8723be: **** _rtl8723be_phy_path_b_iqk: reg 0x948 0x280
[   36.058608] rtl8723be: **** _rtl8723be_phy_path_b_rx_iqk: reg 0x948 0x280
[   36.084617] rtl8723be: **** _rtl8723be_phy_path_a_iqk: reg 0x948 0x0
[   36.094595] rtl8723be: **** _rtl8723be_phy_path_a_rx_iqk: reg 0x948 0x0
[   36.120563] rtl8723be: **** _rtl8723be_phy_path_b_iqk: reg 0x948 0x280
[   36.130531] rtl8723be: **** _rtl8723be_phy_path_b_iqk: reg 0x948 0x280
[   36.140504] rtl8723be: **** _rtl8723be_phy_path_b_rx_iqk: reg 0x948 0x280
[   36.166506] rtl8723be: **** _rtl8723be_phy_iq_calibrate: reg 0x948 0x280
[   36.166587] rtl8723be: **** _rtl8723be_phy_path_a_iqk: reg 0x948 0x0
[   36.176559] rtl8723be: **** _rtl8723be_phy_path_a_iqk: reg 0x948 0x0
[   36.186531] rtl8723be: **** _rtl8723be_phy_path_a_rx_iqk: reg 0x948 0x0
[   36.212499] rtl8723be: **** _rtl8723be_phy_path_b_iqk: reg 0x948 0x280
[   36.222470] rtl8723be: **** _rtl8723be_phy_path_b_rx_iqk: reg 0x948 0x280
[   36.248483] rtl8723be: **** _rtl8723be_phy_iq_calibrate: reg 0x948 0x280
[   36.248597] rtl8723be: **** rtl8723be_phy_iq_calibrate: reg 0x948 0x0
[ 6588.268809] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
[ 6588.269700] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 6588.270296] rtlwifi: rtlwifi: wireless switch is on
[ 6588.273036] rtl8723be 0000:03:00.0 wlp3s0: renamed from wlan0
[ 6801.717794] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
[ 6801.718728] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 6801.719357] rtlwifi: rtlwifi: wireless switch is on
[ 6801.728598] rtl8723be 0000:03:00.0 wlp3s0: renamed from wlan0

cat /etc/modprobe.d/rtl8723be.conf output:

options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2
options rtl8723be ant_sel=2

marked as duplicate by Pilot6, karel, Fabby, Kevin Bowen, pomsky Jun 5 '18 at 3:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Please edit your question to add the result of the terminal commands: dmesg | grep rtl and also: cat /etc/modprobe.d/rtl8723be.conf Welcome to Ask Ubuntu. – chili555 Jun 4 '18 at 13:45
  • I guess -a in tee is wrong. It adds multiple times. – Pilot6 Jun 4 '18 at 15:36
  • yes it is adding multiple time – Tushar Tiwari Jun 5 '18 at 13:16
  • Did you try both 1 and 2 for the value of ant_sel? What's the output of modinfo rtl8723be? – David Foerster Jun 5 '18 at 13:54
  • @TusharTiwari remove the multiple entries. – Pilot6 Jun 5 '18 at 14:10