1

After updating from 16.04 to 18.04, GNOME3 is to slow on my hardware (2010 dual core, 4GB, 128GB SSD)

So I decided to switch to Lubuntu, way faster.

All fine, except: there seems to be no password manager/keyring. So I installed seahorse and libpam-gnome-keyring.

Doesn't work, a terminal is still asking every time in the terminal for my ssh passwords. I can do ssh-add .ssh/id_rsa, but that will save the password only for terminal programs, not for the file-manager.

How do i get the Ubuntu behavior asking a passphrase once in a GUI dialog and saving it for the session for GUI programs and terminal?

It must be a LXDE config issue, all packages are there even when lubuntu-desktop is installed next to Ubuntu, it won't work using the lubuntu-environment.

journalctl | grep -i gnome-keyring-daemon

gnome-keyring-daemon[890]: couldn't set environment variable in session: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Type of message, '(ss)', does not match expected type '(s)'

Starting seahorse

(seahorse:1488): dbind-WARNING **: 08:36:27.966: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
0

At least the last error should be fixed by following the steps explained on this page: nm-applet running, indicator not in taskbar- new behavior in 16.04
For me (on Lubuntu 18.04) just installing the package at-spi2-core sufficed to get rid of this problem.

Seahorse is indeed made for Nautilus, but I found on https://forum.antergos.com/topic/1132/the-file-manager-pcmanfm-doesn-t-remember-passwords/5 the suggestion to install lxpolkit (or try polkit-gnome) and to make it start up automatically.
You can do this by using the non-GUI approach that is explained here: https://askubuntu.com/a/48327/575262
It states that you should add a .desktop file to ~/.config/autostart with a content like:

[Desktop Entry]
Type=Application
Name=<Name of application as displayed>
Exec=<command to execute>
Icon=<full path to icon>
Comment=<optional comments>
X-GNOME-Autostart-enabled=true 

Does this work in your case?

  • Thx, I also found a hint for that package already somewhere else, yes installing that removes the error message but not the problem: a password request in a shell does not open a GUI box. – Janghou Jun 12 '18 at 14:12
  • @Janghou I edited my answer. – ksyrium Jun 12 '18 at 15:58
  • lxpolkit is already installed, and running, also polkitd. It is also working for Krusader and PCMANFM. Asking once. For terminal I seem to do ssh-add manually once. That's OK, but I can't understand that a password (keyring) feature is missing from a default Lubuntu install. Hope this will be fixed for 18.10. LXQt is really promising, (with some KDE programs) – Janghou Jun 20 '18 at 11:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.