1

Since upgrading to Xubuntu 18, the system started playing sounds (beeping).

How do I disable this?

I've tried disabling beeping in X server - nothing changed

xset -b
xset b off

I've looked into amixer, but it says that the system sounds channel is muted.

The kernel module pcspkr is not loaded.

I put set bell-style none in /etc/inputrc and gtk-error-bell = 0 in ~/.gtkrc-2.0 (I don't really know how to figure out what GTK version it should be and whether that's important for config file. I can see this system having some packages with gtk2 and gtk3 in the name).

Finally, I looked into: Settings > Appearance > Enable Sound Events, but the checkbox isn't ticked.

I'm out of ideas... I'm not allowed to open the case: it's a company's computer, and working like this is not really possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.