0

I'm trying to setup my machine to dual boot Ubuntu and Windows 10. I have done this before on my primary PC, but I'm now running into issues doing this on my secondary machine with an older motherboard (specifically 760GM-P34(fx)).

I have Windows 10 installed (UEFI) and have a bootable flash drive that I've installed Ubuntu from by choosing "install Ubuntu alongside Windows 10 boot manager". The installation exited without error and appeared to have completed successfully. I now have both Windows 10 and Ubuntu installed on the same HDD.

On my newer machine (on which I have a functioning dual boot), booting into the GRUB menu was as simple as finding Ubuntu in the boot order and setting it to a higher priority than Windows boot manager. Unfortunately, things are not that simple on the older mobo; the BIOS boot sequence only displays the name of my hard drive, and I cannot see or edit the order of specific boot managers. I have followed many guides and scoured AskUbuntu: I have disabled FastBoot, I've executed bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi in hopes of switching the default boot manager, but I simply can't get anything to work.

It's perhaps worth noting that a screen displaying "2.2TB Infinity" appears after the BIOS screen exits that allows me to enter a boot menu. From there I only have the option to select my HDD, after which it boots straight into Windows.

What can I do to get to the GRUB menu? There is no option to choose Ubuntu/GRUB in my BIOS boot sequence or the 2.2TB Infinity boot menu, so I have no idea how I can access the GRUB menu. As stated, by default the HDD boots straight into Windows. Thanks

0

The default device bootloader (for x64 architectures) is (on the hard disk EFI partition) /EFI/Boot/bootx64.efi, so assuming you have the proper grub installation in /EFI/ubuntu/grubx64.efi, copy (and rename) that grubx64.efi to the /EFI/Boot/bootx64.efi. Try that to boot grub from the hard disk. (To check the EFI partition (assumed to be sda1 below), mount it somewhere,like /mnt and look:

  sudo mount -tvfat /dev/sda1 /mnt
  ls /mnt
  ls /mnt/EFI/Boot

If you are using secure boot, copy/rename /EFI/ubuntu/shimx64.efi to /EFI/Boot/bootx64.efi file, and also copy without renaming grubx64.efi there too (so shim can find it).

  • I have tried this with unfortunately no success. I did find a solution, though, and will post the response shortly. Thanks – sam Jun 4 '18 at 5:09
0

After many hours of searching and experimenting, it is clear that 2.2TB Infinity has been a source of the issues. I've found very little online about this and my situation appears to be a fairly specific case, so I'll step through my observations of the issue and how I resolved them in case anyone finds themselves in the same position I was.

According to MSI:

The 2.2TB Infinity feature allows you to use a 2.2TB or larger HDD as a boot or data drive.

I've been using a 1 TB drive with GPT partitions, so I figured this feature didn't concern me and/or wouldn't have an effect on my dual boot configuration. However, MSI also mentions the following:

Note: 2.2TB Infinity only supports IDE mode.

As far as I know, my drives are using AHCI. Exploring the BIOS, my boot order had 2.2TB Infinity listed before my actual HDD. Each time I booted my computer, I would be greeted with an MSI screen and then a 2.2TB Infinity screen, at which I could explore a boot menu and choose the drive I wanted to boot from.

To test the part 2.2TB Infinity had in the boot process, I disabled it and removed it from my boot order. When I now tried to boot, I found myself stuck with a black screen and a blinking cursor; Windows would not boot from the hard drive alone. Very frustrating stuff but it was clear 2.2TB Infinity played a role in choosing the boot loader, seeing as I could not change the default boot loader in Windows and could not boot into Windows from my hard drive alone.

In a desperate attempt to get Ubuntu working, I left 2.2TB Infinity disabled, changed my boot order to prioritize my bootable flash drive, and reinstalled Ubuntu. After a successful installation, my computer restarted and booted into Ubuntu just fine. If I want to get back into Windows 10, I have to re-enable 2.2TB Infinity in BIOS so that it will take over before my HDD and boot into Windows 10 by default.

I'm by no means an expert when it comes to hardware or low level computing, so I remain thoroughly confused about the technical details of what was going wrong here. My only guess is that 2.2TB Infinity steps in when detecting an IDE drive to assist with the boot loader. Installing an OS with 2.2TB Infinity enabled appears to make booting that OS dependent on it, reducing the user's control over boot options (ie choosing which boot loader to use). Now that I have Ubuntu working without 2.2TB Infinity enabled, I'm nearly positive I will have to reinstall Windows 10 with 2.2TB disabled for me to access the Windows boot manager from the GRUB menu as intended.

If someone has a better idea regarding what's going on here, please feel free to elaborate. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.