25

On Ubuntu 18.04, I have connected my laptop to an external display and I am able to set the external display as primary and external display only mode. But when I turn on my laptop or log out from my session the display login screen is displayed only on my(internal) laptop screen. But once I login the display switches to external only and my laptop screen turns off as expected.

Is there a way I can make the login screen appear only on the external screen on bootup or on logout as in 16.04? also the login screen does not follow my cursor as in 16.04.

28

This is a known and reported bug with gdm3. The current workaround appears to be:

  1. Go into Settings > Devices > Displays and configure your monitors the way you want for your login screen (in your case, internal laptop display disabled). Click the "Save" button when done.
  2. Copy your user's monitors.xml file into the home folder for gdm user.

To copy the monitors.xml file, open a terminal and perform the following:

sudo cp ~/.config/monitors.xml ~gdm/.config/monitors.xml
sudo chown gdm:gdm ~gdm/.config/monitors.xml

Then, reboot and see if your changes persist. If this doesn't work, try going through the whole process again. It took me two times in order to get it to stick. I was also able to reboot with my external display disconnected and it switched back to my internal laptop display. I rebooted again and reconnected it and it switches back to my external monitor.

Hope this helps!

  • Thank you for your suggestion. For some reason it’s not sticking to the external display on boot up, tried about 4 times. Will wait for the bug to be resolved. – Aravind Jun 5 '18 at 1:27
  • It works for me. – jdthood Oct 17 '18 at 7:24
8

I too have an external monitor. This worked for me:

  • Set your display mode as desired using Settings > Devices > Displays
  • Open a terminal window by pressing CtrlAltT and then type:

    sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config

  • Hit Enter

  • Reboot the computer
  • 1
    This was the only answer that worked for me on Ubuntu 18... this folder actually exists unlike /home/gdm – finsbury Oct 20 '18 at 15:05
  • /var/lib/gdm3 is ~gdm , its gdm's home directory. Services user accounts don't usually get home directories in /home . – Amias Jan 5 at 15:41
  • cp: cannot create regular file '/var/lib/gdm/.config': No such file or directory; cp: cannot create regular file '/var/lib/gdm3/.config': No such file or directory; cp: cannot create regular file '~gdm/.config': No such file or directory; Great. Where has the folder moved in Ubuntu 18.04.1 LTS? Does it matter I'm using Gnome 3.28.2 and Wayland? – Ayelis Feb 6 at 18:56
7

This Solved my Isuue:

Go into Settings > Devices > Displays and configure your monitors the way you want for your login screen (in your case, internal laptop display disabled). Click the "Save" button when done.

Copy your user's monitors.xml file into the home folder for gdm user.

To copy the monitors.xml file, open a terminal and perform the following:

sudo cp ~/.config/monitors.xml ~gdm/.config/monitors.xml
sudo chown gdm:gdm ~gdm/.config/monitors.xml

And in the /etc/gdm3/custom.conf uncomment WaylandEnable=false

  • 7
    How is this answer different from Damian T.'s answer? – Kennet Celeste Oct 29 '18 at 15:40
  • 1
    This is the only answer that made the login screen appear on my external monitor. However, when I actually logged in, I only got a black screen and had to recovery-mode to undo the WaylandEndable=false. – drhagen Feb 20 at 13:44

protected by Community Apr 12 at 13:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.