13

Links in Telegram have been opening random apps (image viewer, Calibre, etc), so I checked System Settings > Applications > Default Applications > Web Browser.

Open URLs "in an application based on the contents of the URL" sounds like the culprit, so I changed to "in the following application (Firefox)".

However after leaving this screen or rebooting (both) the setting reverts:

Image1

I ran system settings from console, but I couldn't see any obvious errors.

Update: I ran a fresh install of Kubuntu 18.04 in a virtual machine and tried this, with the same result. Did all available updates and rebooted, tried it again - same result - even though it was on a fresh, stock system.

  • I think this is a bug, and it's new in Kubuntu 18.04. This stuff used to work in Kubuntu 17.10 and 17.04. – Christian Hujer Aug 18 '18 at 13:42
  • Out of curiosity, what did you use to record the screen? – Christian Hujer Aug 18 '18 at 13:55
  • 1
    @ChristianHujer I believe it was SimpleScreen Recorder maartenbaert.be/simplescreenrecorder – Merritt Aug 19 '18 at 14:15
5

Not ideal but I used the with the following command: option on Default Applications dialog in Kubuntu 18.04. For Firefox I would assume this would work: /usr/bin/firefox %s. I prefer Google Chrome so I used: /usr/bin/google-chrome %s

Screenshot of Default Applications dialog in Kubuntu 18.04

| improve this answer | |
2

What was helping me: (I am using Kubuntu 18.04 LTS) find the following file /home/USERNAME/.config/mimeapps.list and edit it like this:

[Default Applications]
application/x-desktop=doublecmd.desktop;
inode/directory=doublecmd.desktop;
inode/symlink=pcmanfm.desktop
text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop

The last two x-scheme-handler/... lines were empty for me, so I wrote google chrome there as I prefer chrome.

| improve this answer | |
0

I experienced the same issue. It looks like a bug.

What helped me was clicking on "File Associations" after "Apply" and then again on "Default Applications". I noticed that my change was applied. After that I closed the settings window and opened it again. My change was still there.

PS: I could reproduce the issue even in 16.04 LTS

| improve this answer | |
0

I encountered a similar issue. For me, it was due to the file ~/.config/mimeapps.list not owned by me.
And it was the only file in this folder not owned by myself.
So I changed the file owner:

cd
cd .config/
sudo chown myUserName:myUserGroup mimeapps.list 

And then I could update my default applications.

| improve this answer | |
0

This bug appears to be resolved in 18.04.3

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.