4

I have a 128GB partitioned SSD with Ubuntu 18.04 and Windows 10 installed, and I want both systems to use the internal 1TB HDD (which has one NTFS partition) for data such as the Downloads, Pictures, Videos and Music folders which should be common between the two OSs.

In order to achieve this, I set up the HDD to be automatically mounted on boot at /mnt/sda1 (using gnome-disks), moved the stuff already in the folders on Ubuntu to the HDD and created symbolic links in /home for those folders (by using ln -s /mnt/sda1/Downloads ~/Downloads etc).

Everything seems to work fine, except all the files I moved are now owned by root and have permissions set to 777. I didn't do this manually so I assume it's a consequence of moving them to the mounted drive, hence my question: how can I change ownership and permissions for these files? I tried using both chown -R and chmod -R but neither worked (nor did they give an error message).

2

You don't change change ownership and permissions of an automatically mounted HDD. Microsoft file systems (NTFS, FAT32, exFAT) get their ownership and permissions when mounted, and directories and files inherit them.

Instead you

  • control the mounting with a line for the partition(s) in the file /etc/fstab

  • if already mounted, you unmount and remount the partition(s) using umount and mount with mount options to get the ownership and permissions, that you want.

The same mount options can be used in /etc/fstab and with mount.

This is described in a detailed way in the following links,

How do I use 'chmod' on an NTFS (or FAT32) partition?

Mount USB with exec flag by default

  • 2
    Another link. help.ubuntu.com/community/MountingWindowsPartitions I like its examples include the windows_names parameter to prevent you from having invalid characters in file names. If Windows 8 or 10 you must also have Windows fast start up off. And Windows may turn it back on with updates: askubuntu.com/questions/843153/… – oldfred Jun 3 '18 at 21:06
  • Thank you both for the links. What I did to get the desired result (mounting the drive as my own user rather than root, with 744 permissions) was add the following line to /etc/fstab (or rather, edit the one added by gnome-disks): /dev/sda1 /mnt/sda1 auto windows_names,nosuid,nodev,nofail,x-gvfs-show,umask=033,uid=1000,gid=1000 0 0 – SakoDaemon Jun 4 '18 at 20:09
  • @IoanaAlexandru, You are welcome, and thanks for sharing your solution :-) – sudodus Jun 5 '18 at 4:34
1

I added this to my /etc/fstab file:

LABEL=Library  /home/john/Libraries ntfs-3g fs-name=Library,x-gvfs-symbolic-icon=Library,permissions,nosuid,nodev,uid=1001,gid=1001,rw,dmask=27,fmask=137 0 0

You'll have to set the LABEL or use the UUID and use your path and your uid and gid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.