1

I installed ubuntu16.04 today and automatically went and installed python from their website.

Now I have python3.5 preinstalled in usr/bin and python3.6 installed in usr/local/bin.

When I type in pip3 -V in bash i get:

pip 8.1.1 from /usr/lib/python3/dist-packages (python 3.5)

When i type in python3 -V i get:

Python 3.6.5

So everything I do with pip3, wont follow through to python3.

How can I fix this?

I cant find how to uninstall just python3.6.

I tried making an alias for python3 in the hope itd overwrite it, it didnt.

I haven tried changing PATH order, I dont know how and if it would even fix it.

Also, apt-get remove python3.6 doesnt work, since it was installed via the browser.

I hope I provided enough info. Id be happy to provide more if needed

  • I solved it. First I removed 'python3' from the python3.6 folder. I also re-added /usr/bin to the PATH. One of those did the job I'm not sure which, but I think the latter. I can still use python 3.6 though by typing python3.6 into bash. My default python is again 3.5 and that's the one where pip3 was working. – Mark Rensen Jun 4 '18 at 9:08
  • @dessert that's exactly what I did, but it did nothing, contrary to what online sources told me it would. – Mark Rensen Jun 4 '18 at 9:15
  • @MarkRensen Please add an answer explaining your solution below. – dessert Jun 4 '18 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.