3

My laptop has an 8th Generation Intel Core i5 8250U processor, with an Nvidia GeForce MX150 GPU, 8GB RAM and a 1TB hard drive. I have installed Ubuntu 16.04 64-bit as a guest OS on Windows 10 64-bit using VirtualBox. Ubuntu was not running smoothly, as there was a lot of lagging.

I searched online for information about the problem and many sources recommended to enable 3D acceleration in the VirtualBox guest OS settings so I did, but after a few loading screens Ubuntu 16.04 doesn't respond and gets stuck on a particular black screen with faint white text of some sort.

Checking Enable 3D Acceleration in the VirtualBox guest OS settings causes a black screen and checking on Enable 2D Video Acceleration results in a message that says: Invalid Settings have been selected.

enter image description here
2D & 3D Acceleration and Video Memory settings in VirtualBox on Windows 10

  • 1
    The image you had attached is a 100% black box - no "fainted" text visible. How did you "turn on 3D acceleration"? – Takkat Jun 3 '18 at 6:13
  • 2
    Welcome to Ask Ubuntu! Could you please add a little more detail? What exactly did you do, what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster Jun 3 '18 at 9:09
  • @Takkat The image is a screenshot, maybe the text is not visible in it, but it is visible on my computer. I turned on the 3D acceleration from the display settings available in the settings option in the VirtualBox launcher – lakshay.angrish Jun 3 '18 at 9:12
  • 1
    @lakshay.angrish: you'd also need to install the guest additions for passthrough of the host GPU but the reason for the black screen may be something else. See askubuntu.com/questions/162075/… for a start. – Takkat Jun 3 '18 at 9:18
  • @Takkat: i had already installed the guest additions, but still I get the black screen – lakshay.angrish Jun 5 '18 at 4:21
3

You are doing exactly the opposite of what you should be doing when your guest OS has limited virtual hardware resources. Enabling 3D acceleration will give the guest OS better performance only if both the host OS and the guest OS have the hardware resources to support it.

Instead of enabling 3D acceleration you should allocate additional virtual hardware resources to the Ubuntu guest OS if it is possible to do so without depriving the Windows 10 host OS of the physical hardware resources that it needs to run properly.

  1. Uncheck Enable 3D Acceleration.

    • In the left pane of VirtualBox click the Ubuntu 16.04 guest OS.

    • Click the Settings icon which looks like a yellow gear.

    • In the Ubuntu 16.04 - Settings window select Display -> Video tab.

    • Uncheck Enable 3D Acceleration (see below screenshot).

  2. Increase the amount of available virtual RAM in the VirtualBox Ubuntu 16.04 guest OS.

    • In the left pane of VirtualBox click the Ubuntu 16.04 guest OS.

    • Click the Settings icon which looks like a yellow gear.

    • In the Ubuntu 16.04 - Settings window select System -> Motherboard tab.

    • Move the Base Memory slider to the right to increase the amount of virtual RAM to 4GB.

  3. Increase the number of virtual processors from the default of 1 to 2.

    • Same as step 2 until you reach the Ubuntu 16.04 - Settings window and then select System -> Processor tab.

    • Move the Processor(s) slider to the right to increase the number of virtual processors from the default of 1 to 2.

  4. Increase VirtualBox video RAM to the maximum amount of 256MB. From the Windows command line run:

    cd "C:\Program Files\Oracle\Virtualbox"
    vboxmanage modifyvm "Name of virtual machine" --vram 256
    

    If you run VirtualBox and go to Display in the Settings window, you would see:

    enter image description here

  5. Click the OK button in the lower right corner of the Ubuntu 16.04 - Settings window to apply the changes in the Ubuntu 16.04 guest OS settings.

  6. Another thing to take into account is X11 vs Wayland. Wayland may not work that well in a virtual machine environment, so you may want to test the desktop behavior by editing the necessary gdm configuration, and enabling/disabling Wayland. This is done through the /etc/gdm/custom.conf file. In there look for the following line and comment/uncomment as needed: source

    #WaylandEnable=false
    
  • 1
    What does 3D acceleration do then? Why was it recommended by other sources? – lakshay.angrish Jun 4 '18 at 3:27
  • I replied to your comment by editing my answer. In addition to inaccurate Ubuntu tutorials there are also a lot of obsolete Ubuntu tutorials on the internet and apparently the search engines do not check each website's content and remove obsolete tutorials from their search results. At Ask Ubuntu we can delete inaccurate content, or correct and update it by editing it. – karel Jun 4 '18 at 3:44
  • 1
    I have core i5 8250U with Nvidia Geforce MX150, 8GB RAM and 1TB Hard drive in my laptop. I have seen 3D acceleration working just fine in laptops that have lower specs than mine. What could be the reason for that? – lakshay.angrish Jun 5 '18 at 4:23
  • Your Nvidia graphics card cannot be used for virtual video RAM in VirtualBox. I'm assuming that you have already tried allocating 4GB RAM, 256MB video RAM and 2 CPUs to the VM guest OS and you're becoming frustrated because it still doesn't work. – karel Jun 5 '18 at 4:27
  • 1
    I allocated the said resources, and subsequently the UI was faster, but it still lags a bit. I do want to know why a black frozen screen appears when 3D acceleration is turned on – lakshay.angrish Jun 5 '18 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.