11

I want to change the Ubuntu Budgie login screen background to the one I'm currently using on my account; Just like it was with the previous Ubuntu versions with Unity with the draw-user-backgrounds option.
I already tried searching for that option or anything with "background" on it with dconf-editor but found nothing.

| improve this question | | | | |
12

Open the Login Window app in the menu under Administration.

If it is missing from the menu then install it:

sudo apt install lightdm-settings

Enter your credentials when prompted. Click on the default background image icon, then navigate to /. Click on home>username>Pictures. Select your desired pic, click Open the in upper right corner, close the app. Log off and you will see your desktop background on the Login screen.

Thanks.

| improve this answer | | | | |
  • 3
    Is there some dependency of lightdm-settings that isn't specified in the package? On my system, which was upgraded from 16.04, I've installed lightdm-settings, but when I launch the Login Window menu item I get prompted for my password but then no window appears. – rakslice Sep 8 '18 at 22:24
  • @rakslice I experience the exact same thing, but my system is a clean install. – beruic Sep 27 '18 at 19:36
  • 6
    lightdm-settings doesn't seem to work in 18.04, it just causes multiple crashes in python on my machine each time I try to open it. – JamesBB Oct 1 '18 at 12:07
  • @JamesBB I think a missing dependency causes the problem you are describing. Most likely the slick-greeter package. You can check which dependency is missing by starting the lightdm-settings in the terminal. – arcety Nov 6 '19 at 14:16
  • try "sudo apt install slick-greeter" for "Settings schema 'x.dm.slick-greeter' is not installed" – kommradHomer Mar 24 at 12:03
21

I have simple Ubuntu 18.04.1

In my opinion the best way to do this:

step1: make backup of the file /usr/share/gnome-shell/theme/ubuntu.css - if you have another desktop for ubuntu you can find file ubuntu.css just using command locate ==> locate ubuntu.css

step2: vim /usr/share/gnome-shell/theme/ubuntu.css and find part below

   #lockDialogGroup {
   background: #2c001e url(resource:///org/gnome/shell/theme/noise-texture.png);
   background-repeat: repeat; }

step3: change it to

   #lockDialogGroup {
   background: #2c001e url(file:///usr/share/backgrounds/warty-final-ubuntu.png);
   background-repeat: no-repeat;
   background-size: cover;
   background-position: center;
    }

clarification: as you can see, we changed
"background: #2c001e url(resource://" part to the ==> "background: #2c001e url(file://"
and then set up path for the image.
I used /usr/share/backgrounds/ for the path with image. Also I added some css properties to center the image.

This is only the css file configuration. That's it)

| improve this answer | | | | |
  • This is the only solution that worked on 18.04.1-Ubuntu, it is conformed. I have wasted 2hours of changing other files no luck, and here it works. Thank You ! – Mirosław Drdzeń Apr 16 '19 at 23:08
  • Be alarmed, that your background-image location must be in an unencrypted part of your hard drive. – rubo77 May 24 '19 at 7:07
2

I tried all of those and none worked. This does, for sure:

As root user, just copy your_image.png to /usr/share/backgrounds and ....

# cd /usr/share/backgrounds
# cp warty-final-ubuntu.png warty-final-ubuntu.png.stock
# rm warty-final-ubuntu.png
# ln -s your_image.png warty-final-ubuntu.png
# reboot

...where your_image.png is the name of the actual image you want to display. The warty one is big: 4096 x 2304. I matched mine to the same size.

| improve this answer | | | | |
2

had the same problem when upgrading to 18.04. 64bit. And the answer is, it depends. Start with 'cat /etc/X11/default-display-manager' and check which greeter manager you got.

Case1. If using gnome-greeter (gdm3, and for example with ubuntu-unity-desktop which is in my case) modify the ubuntu.css as mentioned before and make sure you have replaced 'resource' ident by 'file', otherwise it won't work no matter how hard you try (i promise). Restart your machine. (gnome-tweak-tool works for modifying the background etc.)

Case2. If using the lightdm greeter one can use 'sudo apt install lightdm-gtk-greeter-settings' an adapt changes as needed. Two alternatives are the dconf editor (search for 'greeter', what will show you all the config settings available, and the 'sudo apt install unity-tweak-tool'.

Change between your greeter managers and the different ways changing styles with 'sudo dpkg-reconfigure lightdm' or 'sudo dpkg-reconfigure gdm3'.

Hope it helps

| improve this answer | | | | |
1

lightdm-settings is a good choice, as well as, you can try

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
dconf-editor

In dconf-editor find x/dm/slick-greeter you can edit whatever you want

Cheers

| improve this answer | | | | |
1
  • Run Terminal with Ctrl + Alt + T
  • Run nautilus with sudo by doing (sudo nautilus) - without the brackets
  • Copy your desired background image to /usr/share/backgrounds/
  • Go to /etc/alternatives/gdm3.css and open with Text Editor

Change This

  #lockDialogGroup {
  background: #2c001e url(resource:///org/gnome/shell/theme/noise-texture.png);
  background-repeat: repeat; }

To This

  #lockDialogGroup {
  background: #2c001e url(file:///usr/share/backgrounds/yourimage.png);
  background-repeat: no-repeat;
  background-size: cover;
  background-position: center; }

Click 'Save' when you're done.

Restart your PC

| improve this answer | | | | |
0

After the upgrade to 18.04 I was unable to change the login/lock screen too. So I just replaced the warty-final-ubuntu.png in /usr/share/backgrounds using sudo nautilus with a picture with the same resolution 4096x2304. I renamed it the same : warty-final-ubuntu.png, and deleted the old one. This was fastest and easiest solution...

| improve this answer | | | | |
-3
  1. Install gnome-tweak-tool: sudo apt install gnome-tweak-tool

  2. Click on the app grid icon, type in: gnome-tweak-tool

  3. Open (click on) the gnome-tweak-tool app.

  4. Click on "Appearance".

  5. On the right-hand pane, find "Background." Click on "image" below it and find the jpg file you want for your Ubuntu background.

  6. On the right-hand pane, find "Lock Screen." Click on "image" below it and find the jpg file you want for your Lock Screen page.

Lots of other tools in gnome-tweak-tool that you might like, also.

| improve this answer | | | | |
  • 3
    It doesn't help with the "login screen". – Omar Tariq Aug 14 '18 at 9:26
  • @OmarTariq Totally agree with you. In 18.04 – SaidbakR Oct 21 '18 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.