0

Whenever I try to install anything I get this error (this error is when I try to install firefox)

Setting up virtualbox-ext-pack (5.0.40-0ubuntu1.16.04.1) ...
/var/lib/dpkg/info/virtualbox-ext-pack.postinst: 18: cd: can't cd to /usr/share/virtualbox-ext-pack
dpkg: error processing package virtualbox-ext-pack (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 virtualbox-ext-pack
E: Sub-process /usr/bin/dpkg returned an error code (1)    

Whenever I try to unistall anything I get this error (this error I get when trying to remove virtualbox)

Removing virtualbox-ext-pack (5.0.40-0ubuntu1.16.04.1) ...
/var/lib/dpkg/info/virtualbox-ext-pack.prerm: 4: /var/lib/dpkg/info/virtualbox-ext-pack.prerm: vboxmanage: not found
dpkg: error processing package virtualbox-ext-pack (--purge):
 subprocess installed pre-removal script returned error exit status 127
Errors were encountered while processing:
 virtualbox-ext-pack
E: Sub-process /usr/bin/dpkg returned an error code (1)

Earlier I had tried to install VMware but my laptop does not support required technology and every attempt to get around it failed!

I tried to remove virtualbox with methods described here and this is the result:

Do you want to continue? [Y/n] y
(Reading database ... 873830 files and directories currently installed.)
Removing virtualbox-ext-pack (5.0.40-0ubuntu1.16.04.1) ...
/var/lib/dpkg/info/virtualbox-ext-pack.prerm: 4: /var/lib/dpkg/info/virtualbox-ext-pack.prerm: vboxmanage: not found
dpkg: error processing package virtualbox-ext-pack (--purge):
 subprocess installed pre-removal script returned error exit status 127
Removing virtualbox-qt (5.0.40-dfsg-0ubuntu1.16.04.1) ...
Purging configuration files for virtualbox-qt (5.0.40-dfsg-0ubuntu1.16.04.1) ...
dpkg: virtualbox: dependency problems, but removing anyway as you requested:
 virtualbox-ext-pack depends on virtualbox (>= 5.0.40-dfsg-0~) | virtualbox-5.0; however:
  Package virtualbox is to be removed.
  Package virtualbox-5.1 which provides virtualbox is not installed.
  Package virtualbox-5.0 is not installed.
 virtualbox-ext-pack depends on virtualbox (<< 5.0.40-dfsg-z) | virtualbox-5.0; however:
  Package virtualbox is to be removed.
  Package virtualbox-5.1 which provides virtualbox is not installed.
  Package virtualbox-5.0 is not installed.
 virtualbox-ext-pack depends on virtualbox (>= 5.0.40-dfsg-0~) | virtualbox-5.0; however:
  Package virtualbox is to be removed.
  Package virtualbox-5.1 which provides virtualbox is not installed.
  Package virtualbox-5.0 is not installed.
 virtualbox-ext-pack depends on virtualbox (<< 5.0.40-dfsg-z) | virtualbox-5.0; however:
  Package virtualbox is to be removed.
  Package virtualbox-5.1 which provides virtualbox is not installed.
  Package virtualbox-5.0 is not i
Removing virtualbox (5.0.40-dfsg-0ubuntu1.16.04.1) ...
Purging configuration files for virtualbox (5.0.40-dfsg-0ubuntu1.16.04.1) ...
dpkg: warning: while removing virtualbox, directory '/usr/lib/virtualbox/ExtensionPacks' not empty so not removed
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 virtualbox-ext-pack
E: Sub-process /usr/bin/dpkg returned an error code (1)

While trying sudo apt-upgrade I got this:

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 virtualbox-ext-pack : Depends: virtualbox (>= 5.0.40-dfsg-0~) or
                                virtualbox-5.0 but it is not installable
                       Depends: virtualbox (< 5.0.40-dfsg-z) or
                                virtualbox-5.0 but it is not installable
E: Unmet dependencies. Try using -f.
  • 1. Did you install virtualbox before trying with virtualbox-ext-pack? 2. Please tell us about your computer (brand name and model). – sudodus Jun 2 '18 at 15:16
  • @sudodus ; yes, I first installed virtualbox. I have Lenovo G550 – Mirza Jun 2 '18 at 17:19
  • 1. Is this link desrcibing your computer: Lenovo G550 2958 - 15.6" - P T4200 - Vista Home Premium 64-bit - 4 GB RAM - 320 GB HDD Series? 2. Did the problem start after you installed virtualbox? 3. Have you removed vmware? Can you install some other program, for example htop? – sudodus Jun 2 '18 at 17:28
  • 1
    Not exactly, my computer is Lenovo G550 Model 20023. I didn't notify when exactly it started but befor installing virtual box I had not this problem for sure.I tried but I got the second error. No, I can't install any other program even firefox – Mirza Jun 3 '18 at 5:04
  • How did you install vmware and virtualbox? From the Ubuntu repositories via sudo apt install ... or some other way? -- Whichever method you used, please try to remove them using the matching method to how you installed them. – sudodus Jun 3 '18 at 5:43
1

Let us hope that one or more of the commands by @oldfred and some other experienced users in the following list can help you.

# Oldfred's command list for cleaning and repairing

#houseclean
sudo apt-get autoclean # only removes files that cannot be downloaded anymore (obsolete)
sudo apt-get clean

#refresh
sudo apt-get update #resync package index
sudo apt-get upgrade #newest versions of all packages, update must be run first

#would upgrade you to the latest kernel in the repositories
#dist-upgrade is also able to remove existing packages if required
sudo apt-get dist-upgrade

# fix Broken packages -f 
sudo apt-get -f install
sudo dpkg --configure -a

# Remove lock
# If you are absolutely sure you do not have another upgrade process running.
# Locked dpkg - only if sure you are not running another update.

sudo rm /var/lib/dpkg/lock
sudo dpkg --configure -a 

# added zika's tip for problems with hash sum mismatch

sudo rm /var/lib/apt/lists/*
sudo apt-get update

# added 2F4U's tips for Package Manager & Update Manager problems

Does executing these commands help?

cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get update

This will rebuild the cache.

If it doesn't help, this forum thread has additional suggestions:

GPG key error when attemting to download updates

  • I tried it expect updating distribution due to insufficient disk space. still the same error : The following packages have unmet dependencies: virtualbox-ext-pack : Depends: virtualbox (< 5.0.40-dfsg-z) or virtualbox-5.0 but it is not installable – Mirza Jun 5 '18 at 7:29
  • Did you try to fix broken packages with these commands? sudo apt-get -f install ; sudo dpkg --configure -a – sudodus Jun 5 '18 at 9:35
  • Yes, I tried. I think it might be because of using third-party dependencies – Mirza Jun 5 '18 at 9:52
  • Which third-party dependencies? – sudodus Jun 5 '18 at 10:02
  • Oops, sry, I mean "Third-party repositories" – Mirza Jun 5 '18 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.