3

I just updated to the latest LibreOffice (6.0.4.2) but I changed from the traditionally installed version to the snap version of LibreOffice.

Now, when I run Mendeley (1.19) I no longer see the option to install the LibreOffice plugin.

Could this be a problem with snaps being different from regular installs? Most importantly, is there anyway to get the plugin to work?

I prefer to use snaps so they are always up to date but if I cannot work as I used to, then I'll just go back to the old style of installing apps.

  • 1
    I switched to Zotero because it was just too difficult to get this Mendeley problem fixed. – John Sep 15 '18 at 11:05
4

I had this issue and this is how I solved it on Ubuntu 18.04.1 (in principal it should work with any Linux version):

First make sure you have LibreOffice and Mendeley installed. In my case I installed Mendeley through their .deb file and LibreOffice through Snap. The following line will search for libreoffice in the installed snaps on your computer and if it finds anything it will show it:

snap list | grep -i libreoffice

This is what you get:

libreoffice 6.1.0.3 80 stable canonical✓ -

Then you need to know where Mendeley is storing the OpenOffice plugin. so let's search for it:

sudo find / -name "openOfficePlugin"

This is what I got:

/opt/mendeleydesktop/share/mendeleydesktop/openOfficePlugin

Remember that /opt/ is not readable without sudo.

Now you can copy the openOfficePlugin folder to somewhere that is readable by LibreOffice:

cp -r "/opt/mendeleydesktop/share/mendeleydesktop/openOfficePlugin" "~/Downloads"

Now you have to open the "LibreOffice Writer" and "Mendeley" applications.

From the LibreOffice Writer menu, go to "Tools" > "Extension Manager..." (alternatively in version 6.1.0.3 you can use Ctrl+Alt+E to open the Extension Manager)

enter image description here

Now using the "Add" button, go to the ~/Downloads/openOfficePlugin and open the file (in my case it is Mendeley-1.19.2.oxt but the version might be different in your case).

It takes about a second to add the plugin and then after restarting your LibreOffice, you have the Mendeley toolbar in LibreOffice Writer. If you have your Mendeley open it should automatically connect to it and you can access your library.

enter image description here

  • 1
    This worked for me. The only additional step I had to make was installing some missing python packages: sudo apt-get install libreoffice-script-provider-python – Gorka Oct 3 '18 at 13:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.